# CVE-2024-34559: WordPress Ghost plugin <= 1.4.0 - Sensitive Data Exposure via Log File vulnerability

> Attackers can access sensitive data exposed in log files within the Ghost CMS application, potentially compromising user privacy or system secrets.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 May 2024
- **Updated:** 28 Apr 2026
- **Also known as:** BIT-ghost-2024-34559, GHSA-vhc5-hfx4-87r4

## What is CVE-2024-34559?

CVE-2024-34559 is a high-severity vulnerability in Ghost, published on 9 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Insertion of Sensitive Information into Log File vulnerability in Ghost Foundation Ghost.This issue affects Ghost: from n/a through 1.4.0.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2024-34559?

1 open source package ship an affected version, including ghost.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ghost` | Bitnami | All versions | 1.5.0 |

## How do I fix CVE-2024-34559?

Upgrade ghost to 1.5.0 or later.

## Is CVE-2024-34559 being exploited?

There is no known exploitation of CVE-2024-34559 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34559 and fix it if it is affected.

What it is: CVE-2024-34559 is a high-severity vulnerability in Ghost, published on 9 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-34559 in the wild and no public exploit code.

Affected packages and fixed versions:
- ghost (Bitnami): affected all versions; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34559/ (Markdown: https://insights.sbomify.com/CVE-2024-34559/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34559
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34559
- OSV: https://osv.dev/vulnerability/CVE-2024-34559

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34559/
Summaries are generated and may contain mistakes; the official description above is the record.
