CVE-2024-34693 Apache Superset: Server arbitrary file read
An authenticated attacker can read arbitrary files from the server if MariaDB local_infile is enabled in both server and client configurations.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-34693?
CVE-2024-34693 is a medium-severity path traversal vulnerability in Apache Superset, published on 20 Jun 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Improper Input Validation vulnerability in Apache Superset, allows for an authenticated attacker to create a MariaDB connection with local_infile enabled. If both the MariaDB server (off by default) and the local mysql client on the web server are set to allow for local infile, it's possible for the attacker to execute a specific MySQL/MariaDB SQL command that is able to read files from the server and insert their content on a MariaDB database table.This issue affects Apache Superset: before 3.1.3 and version 4.0.0
Users are recommended to upgrade to version 4.0.1 or 3.1.3, which fixes the issue.
Weakness: CWE-20
Which versions are affected by CVE-2024-34693?
6 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache-superset PyPI | All versions | 3.1.3, 4.0.1 |
apache-superset PyPI | All versions | 3.1.3 |
apache-superset PyPI | All versions | 3.1.3 |
apache-superset PyPI | From 4.0.0 | 4.0.1 |
apache-superset PyPI | From 4.0.0 | 4.0.1 |
superset Bitnami | All versions | 4.1.1 |
Products include Apache Superset.
How do I fix CVE-2024-34693?
Upgrade apache-superset to a fixed version for your release line: 3.1.3 or 4.0.1.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2024-34693 being exploited?
There is no known exploitation of CVE-2024-34693 in the wild and no public exploit code.
Public exploit code: 2 proofs of concept on GitHub.
Other vulnerabilities in Apache Superset
- CVE-2023-27524 Apache Superset Insecure Default Initialization of Resource
- CVE-2022-27479 SQL injection vulnerability in chart data API
- CVE-2018-8021 Deserialization of Untrusted Data in superset
- CVE-2023-49657 Apache Superset: Stored XSS in Dashboard Title and Chart Title
- CVE-2022-43719 Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API
Sources
Also known as BIT-superset-2024-34693, GHSA-hcr7-cqwc-q5gq, PYSEC-2026-1183.