# CVE-2024-34693: Apache Superset: Server arbitrary file read

> An authenticated attacker can read arbitrary files from the server if MariaDB local_infile is enabled in both server and client configurations.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jun 2024
- **Updated:** 21 Feb 2025
- **Also known as:** BIT-superset-2024-34693, GHSA-hcr7-cqwc-q5gq, PYSEC-2026-1183

## What is CVE-2024-34693?

CVE-2024-34693 is a medium-severity path traversal vulnerability in Apache Superset, published on 20 Jun 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Improper Input Validation vulnerability in Apache Superset, allows for an authenticated attacker to create a MariaDB connection with local_infile enabled. If both the MariaDB server (off by default) and the local mysql client on the web server are set to allow for local infile, it's possible for the attacker to execute a specific MySQL/MariaDB SQL command that is able to read files from the server and insert their content on a MariaDB database table.This issue affects Apache Superset: before 3.1.3 and version 4.0.0

Users are recommended to upgrade to version 4.0.1 or 3.1.3, which fixes the issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2024-34693?

6 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-superset` | PyPI | All versions | 3.1.3, 4.0.1 |
| `apache-superset` | PyPI | All versions | 3.1.3 |
| `apache-superset` | PyPI | All versions | 3.1.3 |
| `apache-superset` | PyPI | From 4.0.0 | 4.0.1 |
| `apache-superset` | PyPI | From 4.0.0 | 4.0.1 |
| `superset` | Bitnami | All versions | 4.1.1 |

Products: Apache Superset.

## How do I fix CVE-2024-34693?

Upgrade apache-superset to a fixed version for your release line: 3.1.3 or 4.0.1.

## Is CVE-2024-34693 being exploited?

There is no known exploitation of CVE-2024-34693 in the wild and no public exploit code.

Public exploit code:

- CVE-2024-34693: Server Arbitrary File Read in Apache Superset (github_poc): https://github.com/mbadanoiu/CVE-2024-34693
- An input validation vulnerability in Apache Superset allows an authenticated attacker to create a MariaDB connection with local_infile enabled, potentially leading to local file disclosure on the server. Fixed in Superset versions 3.1.3 and 4.0.1. (github_poc): https://github.com/Mr-r00t11/CVE-2024-34693

## Other vulnerabilities in Apache Superset

- [CVE-2023-27524](https://insights.sbomify.com/CVE-2023-27524/): Apache Superset Insecure Default Initialization of Resource (high 8.9, exploited in the wild)
- [CVE-2022-27479](https://insights.sbomify.com/CVE-2022-27479/): SQL injection vulnerability in chart data API (critical 9.8)
- [CVE-2018-8021](https://insights.sbomify.com/CVE-2018-8021/): Deserialization of Untrusted Data in superset (critical 9.8)
- [CVE-2023-49657](https://insights.sbomify.com/CVE-2023-49657/): Apache Superset: Stored XSS in Dashboard Title and Chart Title (critical 9.6)
- [CVE-2022-43719](https://insights.sbomify.com/CVE-2022-43719/): Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34693 and fix it if it is affected.

What it is: CVE-2024-34693 is a medium-severity path traversal vulnerability in Apache Superset, published on 20 Jun 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-34693 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-superset (PyPI): affected all versions; fixed in 3.1.3, 4.0.1
- apache-superset (PyPI): affected all versions; fixed in 3.1.3
- apache-superset (PyPI): affected all versions; fixed in 3.1.3
- apache-superset (PyPI): affected from 4.0.0; fixed in 4.0.1
- apache-superset (PyPI): affected from 4.0.0; fixed in 4.0.1
- superset (Bitnami): affected all versions; fixed in 4.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34693/ (Markdown: https://insights.sbomify.com/CVE-2024-34693/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34693
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34693
- OSV: https://osv.dev/vulnerability/CVE-2024-34693

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34693/
Summaries are generated and may contain mistakes; the official description above is the record.
