# CVE-2024-34694: LNbits improperly handles potential network and payment failures when using Eclair backend

> Attackers can cause total loss of funds by exploiting improper handling of network timeouts in the Eclair backend integration.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jun 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-3j4h-h3fp-vwww, PYSEC-2026-1580

## What is CVE-2024-34694?

CVE-2024-34694 is a high-severity vulnerability in lnbits, published on 14 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LNbits is a Lightning wallet and accounts system. Paying invoices in Eclair that do not get settled within the internal timeout (about 30s) lead to a payment being considered failed, even though it may still be in flight. This vulnerability can lead to a total loss of funds for the node backend. This vulnerability is fixed in 0.12.6.

Weakness: CWE-754 (Improper Check for Unusual or Exceptional Conditions)

## Which versions are affected by CVE-2024-34694?

3 open source packages ship an affected version, including lnbits.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lnbits` | PyPI | All versions | 0.12.6 |
| `lnbits` | PyPI | All versions | 0.12.6 |
| `lnbits` | PyPI | All versions | 0.12.6 |

## How do I fix CVE-2024-34694?

Upgrade lnbits to 0.12.6 or later.

## Is CVE-2024-34694 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-34694 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34694 and fix it if it is affected.

What it is: CVE-2024-34694 is a high-severity vulnerability in lnbits, published on 14 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-34694 exists.

Affected packages and fixed versions:
- lnbits (PyPI): affected all versions; fixed in 0.12.6
- lnbits (PyPI): affected all versions; fixed in 0.12.6
- lnbits (PyPI): affected all versions; fixed in 0.12.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34694/ (Markdown: https://insights.sbomify.com/CVE-2024-34694/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34694
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34694
- OSV: https://osv.dev/vulnerability/CVE-2024-34694

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34694/
Summaries are generated and may contain mistakes; the official description above is the record.
