# CVE-2024-34699: GZ::CTF allows unprivileged user can perform XSS attacks by constructing malicious team names.

> Unprivileged users can execute cross-site scripting attacks against other users via malicious team names in the GZ::CTF platform.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-p6rq-5x3x-rmhh

## What is CVE-2024-34699?

CVE-2024-34699 is a medium-severity cross-site scripting vulnerability in GZTimeWalker GZCTF, published on 13 May 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

GZ::CTF is a capture the flag platform. Prior to 0.20.1, unprivileged user can perform cross-site scripting attacks on other users by constructing malicious team names. This problem has been fixed in `v0.20.1`.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-34699?


## How do I fix CVE-2024-34699?

No fix has been published for CVE-2024-34699 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-34699 being exploited?

There is no known exploitation of CVE-2024-34699 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34699 and fix it if it is affected.

What it is: CVE-2024-34699 is a medium-severity cross-site scripting vulnerability in GZTimeWalker GZCTF, published on 13 May 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-34699 in the wild and no public exploit code.

Affected product: GZTimeWalker GZCTF. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34699/ (Markdown: https://insights.sbomify.com/CVE-2024-34699/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34699
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34699
- OSV: https://osv.dev/vulnerability/CVE-2024-34699

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34699/
Summaries are generated and may contain mistakes; the official description above is the record.
