# CVE-2024-34709: Directus Lacks Session Tokens Invalidation

> Attackers can reuse captured session tokens after logout to maintain unauthorized access, as tokens are not invalidated server-side.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-g65h-35f3-x2w3

## What is CVE-2024-34709?

CVE-2024-34709 is a medium-severity vulnerability in Monospace Directus, published on 13 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Directus is a real-time API and App dashboard for managing SQL database content. Prior to 10.11.0, session tokens function like the other JWT tokens where they are not actually invalidated when logging out. The `directus_session` gets destroyed and the cookie gets deleted but if the cookie value is captured, it will still work for the entire expiry time which is set to 1 day by default. Making it effectively a long lived unrevokable stateless token instead of the stateful session token it was meant to be. This vulnerability is fixed in 10.11.0.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2024-34709?

2 open source packages ship an affected version, including directus. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `directus` | npm | From 10.10.0 | 10.11.0 |
| `directus` | npm | From 10.10.0 | 10.11.0 |

Products: Monospace Directus.

## How do I fix CVE-2024-34709?

Upgrade directus to 10.11.0 or later.

## Is CVE-2024-34709 being exploited?

There is no known exploitation of CVE-2024-34709 in the wild and no public exploit code.

## Other vulnerabilities in Monospace Directus

- [CVE-2022-26969](https://insights.sbomify.com/CVE-2022-26969/): Insecure default value for CORS configuration (critical 9.8)
- [CVE-2025-55746](https://insights.sbomify.com/CVE-2025-55746/): Directus allows unauthenticated file upload and file modification due to lacking input sanitization (critical 9.3)
- [CVE-2026-35408](https://insights.sbomify.com/CVE-2026-35408/): Directus is Missing Cross-Origin Opener Policy (high 8.7)
- [CVE-2026-61836](https://insights.sbomify.com/CVE-2026-61836/): Directus: Authorization-dependent response served from unsegmented cache key (high 8.6)
- [CVE-2025-30353](https://insights.sbomify.com/CVE-2025-30353/): Directus's webhook trigger flows can leak sensitive data (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34709 and fix it if it is affected.

What it is: CVE-2024-34709 is a medium-severity vulnerability in Monospace Directus, published on 13 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-34709 in the wild and no public exploit code.

Affected packages and fixed versions:
- directus (npm): affected from 10.10.0; fixed in 10.11.0
- directus (npm): affected from 10.10.0; fixed in 10.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34709/ (Markdown: https://insights.sbomify.com/CVE-2024-34709/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34709
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34709
- OSV: https://osv.dev/vulnerability/CVE-2024-34709

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34709/
Summaries are generated and may contain mistakes; the official description above is the record.
