{"answers":{"affected":"4 open source packages ship an affected version, including org.geoserver.main:gs-main and org.geoserver.web:gs-web-app. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-34711 in the wild and no public exploit code.","fix":"Upgrade org.geoserver.main:gs-main to 2.25.0 or later.","what":"CVE-2024-34711 is a critical server-side request forgery vulnerability in geoserver, published on 10 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-34711 and fix it if it is affected.\n\nWhat it is: CVE-2024-34711 is a critical server-side request forgery vulnerability in geoserver, published on 10 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-34711 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.geoserver.main:gs-main (Maven): affected all versions; fixed in 2.25.0\n- org.geoserver.main:gs-main (Maven): affected all versions; fixed in 2.25.0\n- org.geoserver.web:gs-web-app (Maven): affected all versions; fixed in 2.25.0\n- org.geoserver.web:gs-web-app (Maven): affected all versions; fixed in 2.25.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-34711/ (Markdown: https://insights.sbomify.com/CVE-2024-34711/index.md)","id":"CVE-2024-34711","markdown":"https://insights.sbomify.com/CVE-2024-34711/index.md","name":"CVE-2024-34711","record":{"aliases":["GHSA-mc43-4fqr-c965"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"GeoServer","requires_auth":"none","summary":"Attackers can exploit improper URI validation in GeoServer's XML processing to perform SSRF attacks, scanning internal networks and accessing sensitive information.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"geoserver","vendor":"osgeo"}],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"},{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"GeoServer is an open source server that allows users to share and edit geospatial data. An improper URI validation vulnerability exists that enables an unauthorized attacker to perform XML External Entities (XEE) attack, then send GET request to any HTTP server. By default, GeoServer use PreventLocalEntityResolver class from GeoTools to filter out malicious URIs in XML entities before resolving them. The URI must match the regex (?i)(jar:file|http|vfs)[^?#;]*\\\\.xsd. But the regex leaves a chance for attackers to request to any HTTP server or limited file. Attacker can abuse this to scan internal networks and gain information about them then exploit further. GeoServer 2.25.0 and greater default to the use of ENTITY_RESOLUTION_ALLOWLIST and does not require you to provide a system property.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"GeoServer has improper ENTITY_RESOLUTION_ALLOWLIST URI validation in XML Processing (SSRF)","id":"CVE-2024-34711","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"ssrf","year":"2024"},"n_packages":4,"n_references":2,"next":{"headline":"Oceanic allows unsanitized user input to lead to path traversal in URLs","id":"CVE-2024-34712"},"packages":[{"ecosystem":"Maven","fixed":["2.25.0"],"introduced":["0"],"last_affected":[],"package":"org.geoserver.main:gs-main","purl":null,"source":"GHSA-mc43-4fqr-c965"},{"ecosystem":"Maven","fixed":["2.25.0"],"introduced":["0"],"last_affected":[],"package":"org.geoserver.main:gs-main","purl":"pkg:maven/org.geoserver.main/gs-main","source":"GHSA-mc43-4fqr-c965"},{"ecosystem":"Maven","fixed":["2.25.0"],"introduced":["0"],"last_affected":[],"package":"org.geoserver.web:gs-web-app","purl":null,"source":"GHSA-mc43-4fqr-c965"},{"ecosystem":"Maven","fixed":["2.25.0"],"introduced":["0"],"last_affected":[],"package":"org.geoserver.web:gs-web-app","purl":"pkg:maven/org.geoserver.web/gs-web-app","source":"GHSA-mc43-4fqr-c965"}],"prev":{"headline":"Wiki.js Stored XSS through Client Side Template Injection","id":"CVE-2024-34710"},"products":["geoserver"],"published":"2025-06-10","related":[{"cvss_score":9.8,"headline":"Unfiltered SQL Injection Vulnerabilities in Geoserver","id":"CVE-2023-25157","kev_date_added":null,"published":"2023-02-21"},{"cvss_score":8.6,"headline":"Unsecured WMS dynamic styling sld=\u003curl\u003e parameter affords blind unauthenticated SSRF in GeoServer","id":"CVE-2023-41339","kev_date_added":null,"published":"2023-10-24"},{"cvss_score":8.6,"headline":"WPS Server Side Request Forgery in GeoServer","id":"CVE-2023-43795","kev_date_added":null,"published":"2023-10-24"},{"cvss_score":7.5,"headline":"GeoServer Vulnerable to Unauthenticated SSRF via TestWfsPost","id":"CVE-2024-29198","kev_date_added":null,"published":"2025-06-10"},{"cvss_score":7.5,"headline":"GeoServer has an Infinite Loop Vulnerability in Jiffle process","id":"CVE-2025-30145","kev_date_added":null,"published":"2025-06-10"},{"cvss_score":7.5,"headline":"GeoServer allows SSRF via the option for setting a proxy host","id":"CVE-2021-40822","kev_date_added":null,"published":"2022-05-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-10","vendors":["geoserver"]},"summary":"Attackers can exploit improper URI validation in GeoServer's XML processing to perform SSRF attacks, scanning internal networks and accessing sensitive information.","url":"https://insights.sbomify.com/CVE-2024-34711/"}