# CVE-2024-34711: GeoServer has improper ENTITY_RESOLUTION_ALLOWLIST URI validation in XML Processing (SSRF)

> Attackers can exploit improper URI validation in GeoServer's XML processing to perform SSRF attacks, scanning internal networks and accessing sensitive information.

- **Severity:** Critical 9.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2025
- **Updated:** 10 Jun 2025
- **Also known as:** GHSA-mc43-4fqr-c965

## What is CVE-2024-34711?

CVE-2024-34711 is a critical server-side request forgery vulnerability in geoserver, published on 10 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

GeoServer is an open source server that allows users to share and edit geospatial data. An improper URI validation vulnerability exists that enables an unauthorized attacker to perform XML External Entities (XEE) attack, then send GET request to any HTTP server. By default, GeoServer use PreventLocalEntityResolver class from GeoTools to filter out malicious URIs in XML entities before resolving them. The URI must match the regex (?i)(jar:file|http|vfs)[^?#;]*\\.xsd. But the regex leaves a chance for attackers to request to any HTTP server or limited file. Attacker can abuse this to scan internal networks and gain information about them then exploit further. GeoServer 2.25.0 and greater default to the use of ENTITY_RESOLUTION_ALLOWLIST and does not require you to provide a system property.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-611 (Improper Restriction of XML External Entity Reference), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-34711?

4 open source packages ship an affected version, including org.geoserver.main:gs-main and org.geoserver.web:gs-web-app. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.geoserver.main:gs-main` | Maven | All versions | 2.25.0 |
| `org.geoserver.main:gs-main` | Maven | All versions | 2.25.0 |
| `org.geoserver.web:gs-web-app` | Maven | All versions | 2.25.0 |
| `org.geoserver.web:gs-web-app` | Maven | All versions | 2.25.0 |

Products: Osgeo Geoserver.

## How do I fix CVE-2024-34711?

Upgrade org.geoserver.main:gs-main to 2.25.0 or later.

## Is CVE-2024-34711 being exploited?

There is no known exploitation of CVE-2024-34711 in the wild and no public exploit code.

## Other vulnerabilities in geoserver

- [CVE-2023-25157](https://insights.sbomify.com/CVE-2023-25157/): Unfiltered SQL Injection Vulnerabilities in Geoserver (critical 9.8)
- [CVE-2023-41339](https://insights.sbomify.com/CVE-2023-41339/): Unsecured WMS dynamic styling sld=<url> parameter affords blind unauthenticated SSRF in GeoServer (high 8.6)
- [CVE-2023-43795](https://insights.sbomify.com/CVE-2023-43795/): WPS Server Side Request Forgery in GeoServer (high 8.6)
- [CVE-2024-29198](https://insights.sbomify.com/CVE-2024-29198/): GeoServer Vulnerable to Unauthenticated SSRF via TestWfsPost (high 7.5)
- [CVE-2025-30145](https://insights.sbomify.com/CVE-2025-30145/): GeoServer has an Infinite Loop Vulnerability in Jiffle process (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34711 and fix it if it is affected.

What it is: CVE-2024-34711 is a critical server-side request forgery vulnerability in geoserver, published on 10 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-34711 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.geoserver.main:gs-main (Maven): affected all versions; fixed in 2.25.0
- org.geoserver.main:gs-main (Maven): affected all versions; fixed in 2.25.0
- org.geoserver.web:gs-web-app (Maven): affected all versions; fixed in 2.25.0
- org.geoserver.web:gs-web-app (Maven): affected all versions; fixed in 2.25.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34711/ (Markdown: https://insights.sbomify.com/CVE-2024-34711/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34711
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34711
- OSV: https://osv.dev/vulnerability/CVE-2024-34711

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34711/
Summaries are generated and may contain mistakes; the official description above is the record.
