# CVE-2024-34712: Oceanic allows unsanitized user input to lead to path traversal in URLs

> Attackers can manipulate API URLs to delete Discord channels instead of removing bans due to unsanitized input in the Oceanic library.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-5h5v-hw44-f6gg

## What is CVE-2024-34712?

CVE-2024-34712 is a medium-severity path traversal vulnerability in OceanicJS Oceanic, published on 14 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Oceanic is a NodeJS library for interfacing with Discord. Prior to version 1.10.4, input to functions such as `Client.rest.channels.removeBan` is not url-encoded, resulting in specially crafted input such as `../../../channels/{id}` being normalized into the url `/api/v10/channels/{id}`, and deleting a channel rather than removing a ban. Version 1.10.4 fixes this issue. Some workarounds are available. One may sanitize user input, ensuring strings are valid for the purpose they are being used for. One may also encode input with `encodeURIComponent` before providing it to the library.

Weakness: CWE-23 (Relative Path Traversal), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-34712?

2 open source packages ship an affected version, including oceanic.js.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `oceanic.js` | npm | All versions | 1.10.4 |
| `oceanic.js` | npm | All versions | 1.10.4 |

## How do I fix CVE-2024-34712?

Upgrade oceanic.js to 1.10.4 or later.

## Is CVE-2024-34712 being exploited?

There is no known exploitation of CVE-2024-34712 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34712 and fix it if it is affected.

What it is: CVE-2024-34712 is a medium-severity path traversal vulnerability in OceanicJS Oceanic, published on 14 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-34712 in the wild and no public exploit code.

Affected packages and fixed versions:
- oceanic.js (npm): affected all versions; fixed in 1.10.4
- oceanic.js (npm): affected all versions; fixed in 1.10.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34712/ (Markdown: https://insights.sbomify.com/CVE-2024-34712/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34712
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34712
- OSV: https://osv.dev/vulnerability/CVE-2024-34712

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34712/
Summaries are generated and may contain mistakes; the official description above is the record.
