# CVE-2024-34715: Partial Password Exposure Vulnerability in Fides Webserver Logs

> Attackers can read partial database passwords from webserver logs when special characters are used, exposing sensitive credentials.

- **Severity:** Low 2.3 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-8cm5-jfj2-26q7, PYSEC-2026-1337

## What is CVE-2024-34715?

CVE-2024-34715 is a low-severity vulnerability in ethyca fides, published on 29 May 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Fides is an open-source privacy engineering platform. The Fides webserver requires a connection to a hosted PostgreSQL database for persistent storage of application data. If the password used by the webserver for this database connection includes special characters such as `@` and `$`, webserver startup fails and the part of the password following the special character is exposed in webserver error logs. This is caused by improper escaping of the SQLAlchemy password string. As a result users are subject to a partial exposure of hosted database password in webserver logs. The vulnerability has been patched in Fides version `2.37.0`. Users are advised to upgrade to this version or later to secure their systems against this threat. There are no known workarounds for this vulnerability.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2024-34715?

3 open source packages ship an affected version, including ethyca-fides. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ethyca-fides` | PyPI | All versions | 2.37.0 |
| `ethyca-fides` | PyPI | All versions | 2.37.0 |
| `ethyca-fides` | PyPI | All versions | 2.37.0 |

Products: Ethyca Fides.

## How do I fix CVE-2024-34715?

Upgrade ethyca-fides to 2.37.0 or later.

## Is CVE-2024-34715 being exploited?

There is no known exploitation of CVE-2024-34715 in the wild and no public exploit code.

## Other vulnerabilities in ethyca fides

- [CVE-2024-45053](https://insights.sbomify.com/CVE-2024-45053/): Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine (critical 9.1)
- [CVE-2023-41319](https://insights.sbomify.com/CVE-2023-41319/): Remote Code Execution in Custom Integration Upload in Fides (high 8.8)
- [CVE-2025-57817](https://insights.sbomify.com/CVE-2025-57817/): Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation (high 8.6)
- [CVE-2023-48224](https://insights.sbomify.com/CVE-2023-48224/): Cryptographically Weak Generation of One-Time Codes for Identity Verification in ethyca-fides (high 8.2)
- [CVE-2023-46124](https://insights.sbomify.com/CVE-2023-46124/): Server-Side Request Forgery Vulnerability in Custom Integration Upload (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34715 and fix it if it is affected.

What it is: CVE-2024-34715 is a low-severity vulnerability in ethyca fides, published on 29 May 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-34715 in the wild and no public exploit code.

Affected packages and fixed versions:
- ethyca-fides (PyPI): affected all versions; fixed in 2.37.0
- ethyca-fides (PyPI): affected all versions; fixed in 2.37.0
- ethyca-fides (PyPI): affected all versions; fixed in 2.37.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34715/ (Markdown: https://insights.sbomify.com/CVE-2024-34715/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34715
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34715
- OSV: https://osv.dev/vulnerability/CVE-2024-34715

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34715/
Summaries are generated and may contain mistakes; the official description above is the record.
