CVE-2024-34716 PrestaShop vulnerable to XSS via customer contact form in FO, through file upload

Critical 9.7 Published Updated

Attackers can execute scripts via malicious file uploads in the contact form, potentially taking over admin accounts if the customer-thread feature is enabled.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-34716?

CVE-2024-34716 is a critical cross-site scripting vulnerability in Prestashop Prestashop, published on 14 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

PrestaShop is an open source e-commerce web application. A cross-site scripting (XSS) vulnerability that only affects PrestaShops with customer-thread feature flag enabled is present starting from PrestaShop 8.1.0 and prior to PrestaShop 8.1.6. When the customer thread feature flag is enabled through the front-office contact form, a hacker can upload a malicious file containing an XSS that will be executed when an admin opens the attached file in back office. The script injected can access the session and the security token, which allows it to perform any authenticated action in the scope of the administrator's right. This vulnerability is patched in 8.1.6. A workaround is to disable the customer-thread feature-flag.

Weakness: CWE-79

Which versions are affected by CVE-2024-34716?

2 open source packages ship an affected version, including prestashop/prestashop. It affects 1 product.

PackageAffectedFixed in
prestashop/prestashop PackagistFrom 8.1.08.1.6
prestashop/prestashop PackagistFrom 8.1.08.1.6

Products include Prestashop Prestashop.

How do I fix CVE-2024-34716?

Upgrade prestashop/prestashop to 8.1.6 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-34716 being exploited?

There is no known exploitation of CVE-2024-34716 in the wild and no public exploit code.

Public exploit code: 3 proofs of concept on GitHub.

All Prestashop Prestashop vulnerabilities

Sources

Also known as GHSA-45vm-3j38-7p78.

Is CVE-2024-34716 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free