# CVE-2024-34716: PrestaShop vulnerable to XSS via customer contact form in FO, through file upload

> Attackers can execute scripts via malicious file uploads in the contact form, potentially taking over admin accounts if the customer-thread feature is enabled.

- **Severity:** Critical 9.7 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-45vm-3j38-7p78

## What is CVE-2024-34716?

CVE-2024-34716 is a critical cross-site scripting vulnerability in Prestashop Prestashop, published on 14 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

PrestaShop is an open source e-commerce web application. A cross-site scripting (XSS) vulnerability that only affects PrestaShops with customer-thread feature flag enabled is present starting from PrestaShop 8.1.0 and prior to PrestaShop 8.1.6. When the customer thread feature flag is enabled through the front-office contact form, a hacker can upload a malicious file containing an XSS that will be executed when an admin opens the attached file in back office. The script injected can access the session and the security token, which allows it to perform any authenticated action in the scope of the administrator's right. This vulnerability is patched in 8.1.6. A workaround is to disable the customer-thread feature-flag.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-34716?

2 open source packages ship an affected version, including prestashop/prestashop. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prestashop/prestashop` | Packagist | From 8.1.0 | 8.1.6 |
| `prestashop/prestashop` | Packagist | From 8.1.0 | 8.1.6 |

Products: Prestashop Prestashop.

## How do I fix CVE-2024-34716?

Upgrade prestashop/prestashop to 8.1.6 or later.

## Is CVE-2024-34716 being exploited?

There is no known exploitation of CVE-2024-34716 in the wild and no public exploit code.

Public exploit code:

- https://github.com/aelmokhtar/CVE-2024-34716 (github_poc): https://github.com/aelmokhtar/CVE-2024-34716
- https://github.com/0xDTC/Prestashop-CVE-2024-34716 (github_poc): https://github.com/0xDTC/Prestashop-CVE-2024-34716
- This report details exploiting Trickster via an XSS in PrestaShop (CVE-2024-34716) to gain www-data access, extracting database credentials for SSH as james. A root shell in Docker is obtained via ChangeDetection.io (CVE-2024-32651), revealing adam’s credentials, followed by root escalation with CVE-2023-47268 in PrusaSlicer. (github_poc): https://github.com/Pallangyo98/Trickster-HTB

## Other vulnerabilities in Prestashop Prestashop

- [CVE-2023-30839](https://insights.sbomify.com/CVE-2023-30839/): PrestaShop vulnerable to SQL filter bypass leading to arbitrary write requests using "SQL Manager" (critical 10.0)
- [CVE-2008-5791](https://insights.sbomify.com/CVE-2008-5791/): Other in n/a (critical 10.0)
- [CVE-2024-41651](https://insights.sbomify.com/CVE-2024-41651/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2022-31181](https://insights.sbomify.com/CVE-2022-31181/): Remote code execution in prestashop (critical 9.8)
- [CVE-2021-3110](https://insights.sbomify.com/CVE-2021-3110/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34716 and fix it if it is affected.

What it is: CVE-2024-34716 is a critical cross-site scripting vulnerability in Prestashop Prestashop, published on 14 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-34716 in the wild and no public exploit code.

Affected packages and fixed versions:
- prestashop/prestashop (Packagist): affected from 8.1.0; fixed in 8.1.6
- prestashop/prestashop (Packagist): affected from 8.1.0; fixed in 8.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34716/ (Markdown: https://insights.sbomify.com/CVE-2024-34716/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34716
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34716
- OSV: https://osv.dev/vulnerability/CVE-2024-34716

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34716/
Summaries are generated and may contain mistakes; the official description above is the record.
