CVE-2024-34750 Apache Tomcat: HTTP/2 excess header handling DoS
Attackers can cause denial of service in Apache Tomcat by exploiting improper HTTP/2 header handling that keeps connections open indefinitely.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-34750?
CVE-2024-34750 is a high-severity denial of service vulnerability in Apache Tomcat, published on 3 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Handling of Exceptional Conditions, Uncontrolled Resource Consumption vulnerability in Apache Tomcat. When processing an HTTP/2 stream, Tomcat did not handle some cases of excessive HTTP headers correctly. This led to a miscounting of active HTTP/2 streams which in turn led to the use of an incorrect infinite timeout which allowed connections to remain open which should have been closed.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M20, from 10.1.0-M1 through 10.1.24, from 9.0.0-M1 through 9.0.89.
The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.0-M21, 10.1.25 or 9.0.90, which fixes the issue.
Which versions are affected by CVE-2024-34750?
17 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat-coyote. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.25 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.25 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.0-M21 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.0-M21 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.0 to 8.5.100 | None |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.0 to 8.5.100 | None |
11 more packages
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0-M1 | 9.0.90 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0-M1 | 9.0.90 |
tomcat Bitnami | From 9.0.0 | 9.0.90, 10.1.25 |
org.apache.tomcat:tomcat-coyote Maven | From 10.1.0-M1 | 10.1.25 |
org.apache.tomcat:tomcat-coyote Maven | From 10.1.0-M1 | 10.1.25 |
org.apache.tomcat:tomcat-coyote Maven | From 11.0.0-M1 | 11.0.0-M21 |
org.apache.tomcat:tomcat-coyote Maven | From 11.0.0-M1 | 11.0.0-M21 |
org.apache.tomcat:tomcat-coyote Maven | From 8.5.0 to 8.5.100 | None |
org.apache.tomcat:tomcat-coyote Maven | From 8.5.0 to 8.5.100 | None |
org.apache.tomcat:tomcat-coyote Maven | From 9.0.0-M1 | 9.0.90 |
org.apache.tomcat:tomcat-coyote Maven | From 9.0.0-M1 | 9.0.90 |
Linux distribution packages (23)
tomcat AlmaLinux:8 | All versions | 1:9.0.87-1.el8_10.2 |
tomcat-admin-webapps AlmaLinux:8 | All versions | 1:9.0.87-1.el8_10.2 |
tomcat-docs-webapp AlmaLinux:8 | All versions | 1:9.0.87-1.el8_10.2 |
tomcat-el-3.0-api AlmaLinux:8 | All versions | 1:9.0.87-1.el8_10.2 |
tomcat-jsp-2.3-api AlmaLinux:8 | All versions | 1:9.0.87-1.el8_10.2 |
tomcat-lib AlmaLinux:8 | All versions | 1:9.0.87-1.el8_10.2 |
tomcat-servlet-4.0-api AlmaLinux:8 | All versions | 1:9.0.87-1.el8_10.2 |
tomcat-webapps AlmaLinux:8 | All versions | 1:9.0.87-1.el8_10.2 |
tomcat AlmaLinux:9 | All versions | 1:9.0.87-1.el9_4.2 |
tomcat-admin-webapps AlmaLinux:9 | All versions | 1:9.0.87-1.el9_4.2 |
tomcat-docs-webapp AlmaLinux:9 | All versions | 1:9.0.87-1.el9_4.2 |
tomcat-el-3.0-api AlmaLinux:9 | All versions | 1:9.0.87-1.el9_4.2 |
tomcat-jsp-2.3-api AlmaLinux:9 | All versions | 1:9.0.87-1.el9_4.2 |
tomcat-lib AlmaLinux:9 | All versions | 1:9.0.87-1.el9_4.2 |
tomcat-servlet-4.0-api AlmaLinux:9 | All versions | 1:9.0.87-1.el9_4.2 |
tomcat-webapps AlmaLinux:9 | All versions | 1:9.0.87-1.el9_4.2 |
tomcat Rocky Linux:8 | All versions | 1:9.0.87-1.el8_10.2 |
tomcat Rocky Linux:9 | All versions | 1:9.0.87-1.el9_4.2 |
tomcat SUSE:Enterprise Storage 7.1 | All versions | 9.0.91-150200.68.1 |
tomcat SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 9.0.91-150200.68.1 |
tomcat SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 9.0.91-150200.68.1 |
tomcat SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 9.0.91-150200.68.1 |
tomcat SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 9.0.91-150200.68.1 |
Products include Apache Tomcat, Netapp Ontap Tools.
How do I fix CVE-2024-34750?
Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.25, 11.0.0-M21 or 9.0.90.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2024-34750 being exploited?
There is no known exploitation of CVE-2024-34750 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as ALSA-2024:5693, ALSA-2024:5694, BIT-tomcat-2024-34750, CLSA-2025-1737993258, CLSA-2026-1779238039, DEBIAN-CVE-2024-34750 and 11 more.