# CVE-2024-34786: Misconfiguration in UniFi iOS App

> A misconfiguration in the UniFi iOS app can alter SSID names or remove WiFi passwords on standalone access points.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:A/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 9 Jul 2024
- **Updated:** 10 Feb 2025
- **Also known as:** GHSA-h62g-2c7p-qj54

## What is CVE-2024-34786?

CVE-2024-34786 is a medium-severity vulnerability in Ubiquiti UniFi iOS App, published on 9 Jul 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

UniFi iOS app 10.15.0 introduces a misconfiguration on 2nd Generation UniFi Access Points configured as standalone (not using UniFi Network Application) that could cause the SSID name to change and/or the WiFi Password to be removed on the 5GHz Radio.

This vulnerability is fixed in UniFi iOS app 10.15.2 and later.

## Which versions are affected by CVE-2024-34786?


## How do I fix CVE-2024-34786?

No fix has been published for CVE-2024-34786 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-34786 being exploited?

There is no known exploitation of CVE-2024-34786 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34786 and fix it if it is affected.

What it is: CVE-2024-34786 is a medium-severity vulnerability in Ubiquiti UniFi iOS App, published on 9 Jul 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-34786 in the wild and no public exploit code.

Affected product: Ubiquiti UniFi iOS App. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34786/ (Markdown: https://insights.sbomify.com/CVE-2024-34786/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34786
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34786
- OSV: https://osv.dev/vulnerability/CVE-2024-34786

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34786/
Summaries are generated and may contain mistakes; the official description above is the record.
