CVE-2024-34899 AVideo cross-site scripting vulnerability in the view/about.php page

Medium 5.4 Published Updated

Attackers can inject malicious scripts into the AVideo web application, potentially stealing user sessions or executing code in victim browsers.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-34899?

CVE-2024-34899 is a medium-severity cross-site scripting vulnerability in Wwbn Avideo, published on 13 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

WWBN AVideo 12.4 is vulnerable to Cross Site Scripting (XSS).

Weakness: CWE-79

Which versions are affected by CVE-2024-34899?

2 open source packages ship an affected version, including wwbn/avideo. It affects 1 product.

PackageAffectedFixed in
wwbn/avideo PackagistAll versions14.3
wwbn/avideo PackagistAll versions14.3

Products include Wwbn Avideo.

How do I fix CVE-2024-34899?

Upgrade wwbn/avideo to 14.3 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-34899 being exploited?

There is no known exploitation of CVE-2024-34899 in the wild and no public exploit code.

All Wwbn Avideo vulnerabilities

Sources

Also known as GHSA-f98p-2hc5-fm7v.

Is CVE-2024-34899 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free