CVE-2024-3504 Improper Access Control in lunary-ai/lunary

High 8.1 Published Updated

An admin can improperly elevate a user to organization owner, allowing them to delete projects within the organization.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-3504?

CVE-2024-3504 is a high-severity vulnerability in Lunary Lunary, published on 6 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An improper access control vulnerability exists in lunary-ai/lunary versions up to and including 1.2.2, where an admin can update any organization user to the organization owner. This vulnerability allows the elevated user to delete projects within the organization. The issue is resolved in version 1.2.7.

Weakness: CWE-863

Which versions are affected by CVE-2024-3504?

It affects 1 product.

Products include Lunary Lunary.

How do I fix CVE-2024-3504?

No fix has been published for CVE-2024-3504 yet. Limit exposure of the affected software until one is available.

Is CVE-2024-3504 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3504 exists.

All Lunary Lunary vulnerabilities

Sources

Also known as GHSA-xvhp-xj53-p6h7.

Is CVE-2024-3504 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free