CVE-2024-3505 JFrog Self-Hosted Artifactory Proxy configuration accessible to low-privilege users

Medium 4.3 Published Updated

Low-privileged users can read sensitive proxy configuration details in JFrog Artifactory Self-Hosted, requiring an upgrade to remediate.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-3505?

CVE-2024-3505 is a medium-severity vulnerability in Jfrog Artifactory, published on 15 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

JFrog Artifactory Self-Hosted versions below 7.77.3, are vulnerable to sensitive information disclosure whereby a low-privileged authenticated user can read the proxy configuration. This does not affect JFrog cloud deployments.

Weakness: CWE-200

Which versions are affected by CVE-2024-3505?

1 open source package ship an affected version, including artifactory. It affects 1 product.

PackageAffectedFixed in
artifactory BitnamiAll versions7.77.8

Products include Jfrog Artifactory.

How do I fix CVE-2024-3505?

Upgrade artifactory to 7.77.8 or later.

Is CVE-2024-3505 being exploited?

There is no known exploitation of CVE-2024-3505 in the wild and no public exploit code.

All Jfrog Artifactory vulnerabilities

Sources

Also known as BIT-artifactory-2024-3505, GHSA-gfcp-9pcc-558h.

Is CVE-2024-3505 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free