{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-35164 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-35164 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-35164 is a medium-severity code injection vulnerability in Apache Guacamole, published on 2 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-35164 and fix it if it is affected.\n\nWhat it is: CVE-2024-35164 is a medium-severity code injection vulnerability in Apache Guacamole, published on 2 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-35164 in the wild and no public exploit code.\n\nAffected product: Apache Guacamole. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-35164/ (Markdown: https://insights.sbomify.com/CVE-2024-35164/index.md)","id":"CVE-2024-35164","markdown":"https://insights.sbomify.com/CVE-2024-35164/index.md","name":"CVE-2024-35164","record":{"aliases":["GHSA-8wh3-jcvc-qrmq","UBUNTU-CVE-2024-35164"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Guacamole","requires_auth":"low_privilege","summary":"A malicious user with access to a text-based connection can execute arbitrary code on the server via crafted console codes in Apache Guacamole.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"guacamole","vendor":"apache"}],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-129","name":"Improper Validation of Array Index"}],"description":"The terminal emulator of Apache Guacamole 1.5.5 and older does not properly validate console codes received from servers via text-based protocols like SSH. If a malicious user has access to a text-based connection, a specially-crafted sequence of console codes could allow arbitrary code to be executed\nwith the privileges of the running guacd process.\n\nUsers are recommended to upgrade to version 1.6.0, which fixes this issue.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Apache Guacamole: Improper input validation of console codes","id":"CVE-2024-35164","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":0,"n_references":1,"next":{"headline":"WordPress Gutenify plugin \u003c= 1.4.0 - Sensitive Data Exposure via API vulnerability","id":"CVE-2024-35165"},"packages":[],"prev":{"headline":"Path traversal in Download Plugins and Themes from Dashboard","id":"CVE-2024-35162"},"products":["Apache Guacamole"],"published":"2025-07-02","related":[{"cvss_score":8.8,"headline":"Improper validation of SAML responses","id":"CVE-2021-43999","kev_date_added":null,"published":"2022-01-11"},{"cvss_score":8.1,"headline":"Apache Guacamole Race Condition vulnerability","id":"CVE-2017-3158","kev_date_added":null,"published":"2018-01-18"},{"cvss_score":7.5,"headline":"Apache Guacamole: Integer overflow in handling of VNC image buffers","id":"CVE-2023-43826","kev_date_added":null,"published":"2023-12-19"},{"cvss_score":7.5,"headline":"Null dereference in n/a","id":"CVE-2019-19603","kev_date_added":null,"published":"2019-12-09"},{"cvss_score":7.5,"headline":"Missing Encryption of Sensitive Data in Apache Guacamole","id":"CVE-2018-1340","kev_date_added":null,"published":"2019-02-07"},{"cvss_score":6.8,"headline":"Apache Guacamole: Use-after-free in handling of RDP audio input buffer","id":"CVE-2023-30576","kev_date_added":null,"published":"2023-06-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-02-26","vendors":["Apache Software Foundation"]},"summary":"A malicious user with access to a text-based connection can execute arbitrary code on the server via crafted console codes in Apache Guacamole.","url":"https://insights.sbomify.com/CVE-2024-35164/"}