# CVE-2024-35178: Jupyter server on Windows discloses Windows user password hash

> Unauthenticated attackers can leak Windows NTLMv2 password hashes from Jupyter Server, enabling credential cracking or relay attacks to compromise the host or network.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jun 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-hrw6-wg82-cm62, OESA-2024-2308, PYSEC-2024-165, UBUNTU-CVE-2024-35178

## What is CVE-2024-35178?

CVE-2024-35178 is a high-severity vulnerability in jupyter-server jupyter_server, published on 6 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Jupyter Server provides the backend for Jupyter web applications. Jupyter Server on Windows has a vulnerability that lets unauthenticated attackers leak the NTLMv2 password hash of the Windows user running the Jupyter server. An attacker can crack this password to gain access to the Windows machine hosting the Jupyter server, or access other network-accessible machines or 3rd party services using that credential. Or an attacker perform an NTLM relay attack without cracking the credential to gain access to other network-accessible machines. This vulnerability is fixed in 2.14.1.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-35178?

3 open source packages ship an affected version, including jupyter-server and jupyter_server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyter-server` | PyPI | All versions | 2.14.1 |
| `jupyter-server` | PyPI | All versions | 2.14.1 |
| `jupyter_server` | PyPI | All versions | 2.14.1 |

Products: Jupyter Jupyter Server.

## How do I fix CVE-2024-35178?

Upgrade jupyter-server to 2.14.1 or later.

## Is CVE-2024-35178 being exploited?

There is no known exploitation of CVE-2024-35178 in the wild and no public exploit code.

## Other vulnerabilities in jupyter-server jupyter_server

- [CVE-2026-44727](https://insights.sbomify.com/CVE-2026-44727/): Jupyter Server: Stored XSS in `NbconvertFileHandler` / `NbconvertPostHandler` via missing `sandbox` CSP (critical 9.3)
- [CVE-2026-35397](https://insights.sbomify.com/CVE-2026-35397/): jupyter-server path traversal allows access to sibling directories sharing root_dir name prefix (high 7.6)
- [CVE-2026-40110](https://insights.sbomify.com/CVE-2026-40110/): jupyter-server CORS origin validation bypass via unanchored regex in allow_origin_pat (high 7.6)
- [CVE-2026-40934](https://insights.sbomify.com/CVE-2026-40934/): jupyter-server authentication cookies remain valid after password reset due to static cookie secret (high 7.6)
- [CVE-2022-24757](https://insights.sbomify.com/CVE-2022-24757/): Sensitive Auth & Cookie data stored in Jupyter server logs (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-35178 and fix it if it is affected.

What it is: CVE-2024-35178 is a high-severity vulnerability in jupyter-server jupyter_server, published on 6 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-35178 in the wild and no public exploit code.

Affected packages and fixed versions:
- jupyter-server (PyPI): affected all versions; fixed in 2.14.1
- jupyter-server (PyPI): affected all versions; fixed in 2.14.1
- jupyter_server (PyPI): affected all versions; fixed in 2.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-35178/ (Markdown: https://insights.sbomify.com/CVE-2024-35178/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-35178
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-35178
- OSV: https://osv.dev/vulnerability/CVE-2024-35178

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-35178/
Summaries are generated and may contain mistakes; the official description above is the record.
