# CVE-2024-35180: OMERO.web JSONP callback vulnerability

> Attackers can execute arbitrary JavaScript via unvalidated JSONP callbacks in OMERO.web, requiring JSONP to be enabled.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-vr85-5pwx-c6gq, PYSEC-2026-1718

## What is CVE-2024-35180?

CVE-2024-35180 is a medium-severity cross-site scripting vulnerability in omero-web, published on 21 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

OMERO.web provides a web based client and plugin infrastructure. There is currently no escaping or validation of the `callback` parameter that can be passed to various OMERO.web endpoints that have JSONP enabled. This vulnerability has been patched in version 5.26.0.

Weakness: CWE-830 (Inclusion of Web Functionality from an Untrusted Source)

## Which versions are affected by CVE-2024-35180?

3 open source packages ship an affected version, including omero-web. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `omero-web` | PyPI | All versions | 5.26.0 |
| `omero-web` | PyPI | All versions | 5.26.0 |
| `omero-web` | PyPI | All versions | 5.26.0 |

Products: Openmicroscopy Omero-Web.

## How do I fix CVE-2024-35180?

Upgrade omero-web to 5.26.0 or later.

## Is CVE-2024-35180 being exploited?

There is no known exploitation of CVE-2024-35180 in the wild and no public exploit code.

## Other vulnerabilities in omero-web

- [CVE-2025-54791](https://insights.sbomify.com/CVE-2025-54791/): OMERO.web displays unecessary user information when requesting to reset the password (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-35180 and fix it if it is affected.

What it is: CVE-2024-35180 is a medium-severity cross-site scripting vulnerability in omero-web, published on 21 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-35180 in the wild and no public exploit code.

Affected packages and fixed versions:
- omero-web (PyPI): affected all versions; fixed in 5.26.0
- omero-web (PyPI): affected all versions; fixed in 5.26.0
- omero-web (PyPI): affected all versions; fixed in 5.26.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-35180/ (Markdown: https://insights.sbomify.com/CVE-2024-35180/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-35180
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-35180
- OSV: https://osv.dev/vulnerability/CVE-2024-35180

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-35180/
Summaries are generated and may contain mistakes; the official description above is the record.
