# CVE-2024-35191: verbb/formie Server-Side Template Injection for variable-enabled settings

> Users with form settings access can inject malicious Twig code into fields, leading to remote code execution upon submission or rendering.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-v45m-hxqp-fwf5

## What is CVE-2024-35191?

CVE-2024-35191 is a medium-severity code injection vulnerability in verbb formie, published on 20 May 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Formie is a Craft CMS plugin for creating forms. Prior to 2.1.6, users with access to a form's settings can include malicious Twig code into fields that support Twig. These might be the Submission Title or the Success Message. This code will then be executed upon creating a submission, or rendering the text.  This has been fixed in Formie 2.1.6.

Weakness: CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2024-35191?

2 open source packages ship an affected version, including verbb/formie. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `verbb/formie` | Packagist | All versions | 2.1.6 |
| `verbb/formie` | Packagist | All versions | 2.1.6 |

Products: Verbb Formie.

## How do I fix CVE-2024-35191?

Upgrade verbb/formie to 2.1.6 or later.

## Is CVE-2024-35191 being exploited?

There is no known exploitation of CVE-2024-35191 in the wild and no public exploit code.

## Other vulnerabilities in verbb formie

- [CVE-2025-32427](https://insights.sbomify.com/CVE-2025-32427/): Formie has a XSS vulnerability for importing forms (medium 5.3)
- [CVE-2025-32426](https://insights.sbomify.com/CVE-2025-32426/): Formie has a XSS vulnerability for email notification content for preview (medium 4.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-35191 and fix it if it is affected.

What it is: CVE-2024-35191 is a medium-severity code injection vulnerability in verbb formie, published on 20 May 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-35191 in the wild and no public exploit code.

Affected packages and fixed versions:
- verbb/formie (Packagist): affected all versions; fixed in 2.1.6
- verbb/formie (Packagist): affected all versions; fixed in 2.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-35191/ (Markdown: https://insights.sbomify.com/CVE-2024-35191/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-35191
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-35191
- OSV: https://osv.dev/vulnerability/CVE-2024-35191

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-35191/
Summaries are generated and may contain mistakes; the official description above is the record.
