# CVE-2024-35194: Stacklok Minder vulnerable to denial of service from maliciously crafted templates


- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-crgc-2583-rw27, GO-2024-2871

## What is CVE-2024-35194?

CVE-2024-35194 is a medium-severity vulnerability in stacklok minder, published on 20 May 2024. 

### Official description

Minder is a software supply chain security platform. Prior to version 0.0.50, Minder engine is susceptible to a denial of service from memory exhaustion that can be triggered from maliciously created templates. Minder engine uses templating to generate strings for various use cases such as URLs, messages for pull requests, descriptions for advisories. In some cases can the user control both the template and the params for it, and in a subset of these cases, Minder reads the generated template entirely into memory. When Minders templating meets both of these conditions, an attacker is able to generate large enough templates that Minder will exhaust memory and crash. This vulnerability is fixed in 0.0.50.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-35194?

3 open source packages ship an affected version, including github.com/stacklok/minder.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/stacklok/minder` | Go | All versions | 0.0.50 |
| `github.com/stacklok/minder` | Go | All versions | 0.0.50 |
| `github.com/stacklok/minder` | Go | All versions | 0.0.50 |

## How do I fix CVE-2024-35194?

Upgrade github.com/stacklok/minder to 0.0.50 or later.

## Is CVE-2024-35194 being exploited?

There is no known exploitation of CVE-2024-35194 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-35194 and fix it if it is affected.

What it is: CVE-2024-35194 is a medium-severity vulnerability in stacklok minder, published on 20 May 2024. 
Exploitation: There is no known exploitation of CVE-2024-35194 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/stacklok/minder (Go): affected all versions; fixed in 0.0.50
- github.com/stacklok/minder (Go): affected all versions; fixed in 0.0.50
- github.com/stacklok/minder (Go): affected all versions; fixed in 0.0.50

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-35194/ (Markdown: https://insights.sbomify.com/CVE-2024-35194/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-35194
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-35194
- OSV: https://osv.dev/vulnerability/CVE-2024-35194

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-35194/
Summaries are generated and may contain mistakes; the official description above is the record.
