# CVE-2024-35196: Slack integration leaks sensitive information in logs in Sentry

> Sentry logs leak Slack verification tokens, allowing attackers to forge requests if using deprecated tokens in self-hosted configurations.

- **Severity:** Low 2.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-c2g2-gx4j-rj3j, PYSEC-2026-1913

## What is CVE-2024-35196?

CVE-2024-35196 is a low-severity vulnerability in getsentry sentry, published on 31 May 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Sentry is a developer-first error tracking and performance monitoring platform. Sentry's Slack integration incorrectly records the incoming request body in logs. This request data can contain sensitive information, including the deprecated Slack verification token. With this verification token, it is possible under specific configurations, an attacker can forge requests and act as the Slack integration. The request body is leaked in log entries matching `event == "slack.*" && name == "sentry.integrations.slack" && request_data == *`. The deprecated slack verification token, will be found in the `request_data.token` key. **SaaS users** do not need to take any action. **Self-hosted users** should upgrade to version 24.5.0 or higher, rotate their Slack verification token, and use the Slack Signing Secret instead of the verification token. For users only using the `slack.signing-secret` in their self-hosted configuration, the legacy verification token is not used to verify the webhook payload. It is ignored. Users unable to upgrade should either set the `slack.signing-secret` instead of `slack.verification-token`. The signing secret is Slack's recommended way of authenticating webhooks. By having `slack.singing-secret` set, Sentry self-hosted will no longer use the verification token for authentication of the webhooks, regardless of whether `slack.verification-token` is set or not. Alternatively if the self-hosted instance is unable to be upgraded or re-configured to use the `slack.signing-secret`, the logging configuration can be adjusted to not generate logs from the integration. The default logging configuration can be found in `src/sentry/conf/server.py`. **Services should be restarted once the configuration change is saved.**

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2024-35196?

3 open source packages ship an affected version, including sentry.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sentry` | PyPI | From 24.3.0 | 24.5.0 |
| `sentry` | PyPI | From 24.3.0 | 24.5.0 |
| `sentry` | PyPI | From 24.3.0 | 24.5.0 |

## How do I fix CVE-2024-35196?

Upgrade sentry to 24.5.0 or later.

## Is CVE-2024-35196 being exploited?

There is no known exploitation of CVE-2024-35196 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-35196 and fix it if it is affected.

What it is: CVE-2024-35196 is a low-severity vulnerability in getsentry sentry, published on 31 May 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-35196 in the wild and no public exploit code.

Affected packages and fixed versions:
- sentry (PyPI): affected from 24.3.0; fixed in 24.5.0
- sentry (PyPI): affected from 24.3.0; fixed in 24.5.0
- sentry (PyPI): affected from 24.3.0; fixed in 24.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-35196/ (Markdown: https://insights.sbomify.com/CVE-2024-35196/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-35196
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-35196
- OSV: https://osv.dev/vulnerability/CVE-2024-35196

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-35196/
Summaries are generated and may contain mistakes; the official description above is the record.
