{"answers":{"affected":"3 open source packages ship an affected version, including torchserve. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-35199 in the wild and no public exploit code.","fix":"Upgrade torchserve to 0.11.0 or later.","what":"CVE-2024-35199 is a high-severity vulnerability in pytorch serve, published on 18 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-35199 and fix it if it is affected.\n\nWhat it is: CVE-2024-35199 is a high-severity vulnerability in pytorch serve, published on 18 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-35199 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- torchserve (PyPI): affected from 0.3.0; fixed in 0.11.0\n- torchserve (PyPI): affected from 0.3.0; fixed in 0.11.0\n- torchserve (PyPI): affected from 0.3.0; fixed in 0.11.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-35199/ (Markdown: https://insights.sbomify.com/CVE-2024-35199/index.md)","id":"CVE-2024-35199","markdown":"https://insights.sbomify.com/CVE-2024-35199/index.md","name":"CVE-2024-35199","record":{"aliases":["GHSA-hhpg-v63p-wp7w","PYSEC-2026-1971"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PyTorch model server","requires_auth":"none","summary":"TorchServe exposes gRPC ports on all network interfaces by default, allowing unauthorized access to model serving interfaces.","user_interaction":"not_required","vuln_class":"misconfiguration"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"torchserve","vendor":"pytorch"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-668","name":"Exposure of Resource to Wrong Sphere"}],"description":"TorchServe is a flexible and easy-to-use tool for serving and scaling PyTorch models in production. In affected versions the two gRPC ports 7070 and 7071, are not bound to [localhost](http://localhost/) by default, so when TorchServe is launched, these two interfaces are bound to all interfaces. Customers using PyTorch inference Deep Learning Containers (DLC) through Amazon SageMaker and EKS are not affected. This issue in TorchServe has been fixed in PR #3083. TorchServe release 0.11.0 includes the fix to address this vulnerability. Users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"TorchServe gRPC Port Exposure","id":"CVE-2024-35199","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"misconfiguration","year":"2024"},"n_packages":3,"n_references":3,"next":{"headline":"NGINX HTTP/3 QUIC vulnerability","id":"CVE-2024-35200"},"packages":[{"ecosystem":"PyPI","fixed":["0.11.0"],"introduced":["0.3.0"],"last_affected":[],"package":"torchserve","purl":null,"source":"GHSA-hhpg-v63p-wp7w"},{"ecosystem":"PyPI","fixed":["0.11.0"],"introduced":["0.3.0"],"last_affected":[],"package":"torchserve","purl":"pkg:pypi/torchserve","source":"GHSA-hhpg-v63p-wp7w"},{"ecosystem":"PyPI","fixed":["0.11.0"],"introduced":["0.3.0"],"last_affected":[],"package":"torchserve","purl":"pkg:pypi/torchserve","source":"PYSEC-2026-1971"}],"prev":{"headline":"TorchServe bypass allowed_urls configuration","id":"CVE-2024-35198"},"products":["serve"],"published":"2024-07-18","related":[{"cvss_score":10,"headline":"TorchServe Server-Side Request Forgery","id":"CVE-2023-43654","kev_date_added":null,"published":"2023-09-28"},{"cvss_score":9.8,"headline":"TorchServe bypass allowed_urls configuration","id":"CVE-2024-35198","kev_date_added":null,"published":"2024-07-18"},{"cvss_score":5.3,"headline":"TorchServe ZipSlip","id":"CVE-2023-48299","kev_date_added":null,"published":"2023-11-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-07","vendors":["pytorch"]},"summary":"TorchServe exposes gRPC ports on all network interfaces by default, allowing unauthorized access to model serving interfaces.","url":"https://insights.sbomify.com/CVE-2024-35199/"}