# CVE-2024-35218: Umbraco CMS Vulnerable to Stored XSS on Content Page Through Markdown Editor Preview Pane

> Attackers with backoffice access can inject malicious scripts via the Markdown editor preview pane, leading to stored XSS attacks on the website.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-gvpc-3pj6-4m9w

## What is CVE-2024-35218?

CVE-2024-35218 is a medium-severity cross-site scripting vulnerability in Umbraco Umbraco Cms, published on 21 May 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Umbraco CMS is an ASP.NET CMS used by more than 730.000 websites. Stored Cross-site scripting (XSS) enable attackers that have access to backoffice to bring malicious content into a website or application. This vulnerability has been patched in version(s) 8.18.13, 10.8.4, 12.3.7, 13.1.1 by implementing IHtmlSanitizer.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-35218?

8 open source packages ship an affected version, including UmbracoCms.Core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `UmbracoCms.Core` | NuGet | From 10.0.0 | 10.8.4 |
| `UmbracoCms.Core` | NuGet | From 10.0.0 | 10.8.4 |
| `UmbracoCms.Core` | NuGet | From 12.0.0 | 12.3.7 |
| `UmbracoCms.Core` | NuGet | From 12.0.0 | 12.3.7 |
| `UmbracoCms.Core` | NuGet | From 13.0.0 | 13.1.1 |
| `UmbracoCms.Core` | NuGet | From 13.0.0 | 13.1.1 |
| `UmbracoCms.Core` | NuGet | From 8.0.0 | 8.18.13 |
| `UmbracoCms.Core` | NuGet | From 8.0.0 | 8.18.13 |

Products: Umbraco Umbraco Cms.

## How do I fix CVE-2024-35218?

Upgrade UmbracoCms.Core to a fixed version for your release line: 10.8.4, 12.3.7, 13.1.1 or 8.18.13.

## Is CVE-2024-35218 being exploited?

There is no known exploitation of CVE-2024-35218 in the wild and no public exploit code.

## Other vulnerabilities in Umbraco Umbraco Cms

- [CVE-2025-67288](https://insights.sbomify.com/CVE-2025-67288/): Umbraco CMS has an arbitrary file upload vulnerability (critical 10.0)
- [CVE-2014-10074](https://insights.sbomify.com/CVE-2014-10074/): File upload in n/a (critical 9.8)
- [CVE-2012-1301](https://insights.sbomify.com/CVE-2012-1301/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2012-10054](https://insights.sbomify.com/CVE-2012-10054/): Umbraco CMS < 4.7.1 codeEditorSave.asmx RCE (critical 9.3)
- [CVE-2025-32017](https://insights.sbomify.com/CVE-2025-32017/): Umbraco has a Management API Vulnerability to Path Traversal With Authenticated Users (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-35218 and fix it if it is affected.

What it is: CVE-2024-35218 is a medium-severity cross-site scripting vulnerability in Umbraco Umbraco Cms, published on 21 May 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-35218 in the wild and no public exploit code.

Affected packages and fixed versions:
- UmbracoCms.Core (NuGet): affected from 10.0.0; fixed in 10.8.4
- UmbracoCms.Core (NuGet): affected from 10.0.0; fixed in 10.8.4
- UmbracoCms.Core (NuGet): affected from 12.0.0; fixed in 12.3.7
- UmbracoCms.Core (NuGet): affected from 12.0.0; fixed in 12.3.7
- UmbracoCms.Core (NuGet): affected from 13.0.0; fixed in 13.1.1
- UmbracoCms.Core (NuGet): affected from 13.0.0; fixed in 13.1.1
- UmbracoCms.Core (NuGet): affected from 8.0.0; fixed in 8.18.13
- UmbracoCms.Core (NuGet): affected from 8.0.0; fixed in 8.18.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-35218/ (Markdown: https://insights.sbomify.com/CVE-2024-35218/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-35218
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-35218
- OSV: https://osv.dev/vulnerability/CVE-2024-35218

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-35218/
Summaries are generated and may contain mistakes; the official description above is the record.
