# CVE-2024-35219: OpenAPI Generator Online - Arbitrary File Read/Delete

> Attackers can read and delete arbitrary files via path traversal in the output folder option of OpenAPI Generator Online.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-g3hr-p86p-593h

## What is CVE-2024-35219?

CVE-2024-35219 is a high-severity path traversal vulnerability in OpenAPITools openapi-generator, published on 27 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenAPI Generator allows generation of API client libraries (SDK generation), server stubs, documentation and configuration automatically given an OpenAPI Spec. Prior to version 7.6.0, attackers can exploit a path traversal vulnerability to read and delete files and folders from an arbitrary, writable directory as anyone can set the output folder when submitting the request via the `outputFolder` option. The issue was fixed in version 7.6.0 by removing the usage of the `outputFolder` option. No known workarounds are available.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-35219?

2 open source packages ship an affected version, including org.openapitools:openapi-generator-online.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.openapitools:openapi-generator-online` | Maven | All versions | 7.6.0 |
| `org.openapitools:openapi-generator-online` | Maven | All versions | 7.6.0 |

## How do I fix CVE-2024-35219?

Upgrade org.openapitools:openapi-generator-online to 7.6.0 or later.

## Is CVE-2024-35219 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-35219 exists.

Public exploit code:

- OpenAPI Generator <= 7.5.0 - Arbitrary File Read/Delete (nuclei): http/cves/2024/CVE-2024-35219.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-35219 and fix it if it is affected.

What it is: CVE-2024-35219 is a high-severity path traversal vulnerability in OpenAPITools openapi-generator, published on 27 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-35219 exists.

Affected packages and fixed versions:
- org.openapitools:openapi-generator-online (Maven): affected all versions; fixed in 7.6.0
- org.openapitools:openapi-generator-online (Maven): affected all versions; fixed in 7.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-35219/ (Markdown: https://insights.sbomify.com/CVE-2024-35219/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-35219
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-35219
- OSV: https://osv.dev/vulnerability/CVE-2024-35219

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-35219/
Summaries are generated and may contain mistakes; the official description above is the record.
