{"answers":{"affected":"2 open source packages ship an affected version, including @fastify/session.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-35220 exists.","fix":"Upgrade @fastify/session to 10.9.0 or later.","what":"CVE-2024-35220 is a high-severity vulnerability in fastify session, published on 21 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-35220 and fix it if it is affected.\n\nWhat it is: CVE-2024-35220 is a high-severity vulnerability in fastify session, published on 21 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-35220 exists.\n\nAffected packages and fixed versions:\n- @fastify/session (npm): affected all versions; fixed in 10.9.0\n- @fastify/session (npm): affected all versions; fixed in 10.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-35220/ (Markdown: https://insights.sbomify.com/CVE-2024-35220/index.md)","id":"CVE-2024-35220","markdown":"https://insights.sbomify.com/CVE-2024-35220/index.md","name":"CVE-2024-35220","record":{"aliases":["GHSA-pj27-2xvp-4qxg"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Fastify session plugin","requires_auth":"none","summary":"Attackers can reuse expired session cookies because the plugin fails to correctly detect expiration, bypassing session termination controls.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-613","name":"DEPRECATED: Insufficient Session Expiration"}],"description":"@fastify/session is a session plugin for fastify. Requires the @fastify/cookie plugin. When restoring the cookie from the session store, the `expires` field is overriden if the `maxAge` field was set.\nThis means a cookie is never correctly detected as expired and thus expired sessions are not destroyed. This vulnerability has been patched 10.8.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"@fastify/session reuses destroyed session cookie","id":"CVE-2024-35220","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"Denial of service when publishing a package on rubygems.org","id":"CVE-2024-35221"},"packages":[{"ecosystem":"npm","fixed":["10.9.0"],"introduced":["0"],"last_affected":[],"package":"@fastify/session","purl":null,"source":"GHSA-pj27-2xvp-4qxg"},{"ecosystem":"npm","fixed":["10.9.0"],"introduced":["0"],"last_affected":[],"package":"@fastify/session","purl":"pkg:npm/%40fastify/session","source":"GHSA-pj27-2xvp-4qxg"}],"prev":{"headline":"OpenAPI Generator Online - Arbitrary File Read/Delete","id":"CVE-2024-35219"},"products":["session"],"published":"2024-05-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["fastify"]},"summary":"Attackers can reuse expired session cookies because the plugin fails to correctly detect expiration, bypassing session termination controls.","url":"https://insights.sbomify.com/CVE-2024-35220/"}