CVE-2024-35227 Discourse vulnerable to DoS through Onebox

High 7.5 Published Updated

Attackers can cause denial of service in Discourse forums by submitting malicious URLs to the Onebox feature.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-35227?

CVE-2024-35227 is a high-severity denial of service vulnerability in Discourse Discourse, published on 3 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Discourse is an open-source discussion platform. Prior to version 3.2.3 on the `stable` branch and version 3.3.0.beta3 on the `tests-passed` branch, Oneboxing against a carefully crafted malicious URL can reduce the availability of a Discourse instance. The problem has been patched in version 3.2.3 on the `stable` branch and version 3.3.0.beta3 on the `tests-passed` branch. There are no known workarounds available for this vulnerability.

Weakness: CWE-20

Which versions are affected by CVE-2024-35227?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.2.3

Products include Discourse Discourse.

How do I fix CVE-2024-35227?

Upgrade discourse to 3.2.3 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-35227 being exploited?

There is no known exploitation of CVE-2024-35227 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2024-35227, GHSA-664f-xwjw-752c.

Is CVE-2024-35227 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free