{"answers":{"affected":"1 open source package ship an affected version, including discourse. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-35227 in the wild and no public exploit code.","fix":"Upgrade discourse to 3.2.3 or later.","what":"CVE-2024-35227 is a high-severity denial of service vulnerability in Discourse Discourse, published on 3 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-35227 and fix it if it is affected.\n\nWhat it is: CVE-2024-35227 is a high-severity denial of service vulnerability in Discourse Discourse, published on 3 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-35227 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- discourse (Bitnami): affected all versions; fixed in 3.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-35227/ (Markdown: https://insights.sbomify.com/CVE-2024-35227/index.md)","id":"CVE-2024-35227","markdown":"https://insights.sbomify.com/CVE-2024-35227/index.md","name":"CVE-2024-35227","record":{"aliases":["BIT-discourse-2024-35227","GHSA-664f-xwjw-752c"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Discourse forum","requires_auth":"none","summary":"Attackers can cause denial of service in Discourse forums by submitting malicious URLs to the Onebox feature.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"discourse","vendor":"discourse"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Discourse is an open-source discussion platform. Prior to version 3.2.3 on the `stable` branch and version 3.3.0.beta3 on the `tests-passed` branch, Oneboxing against a carefully crafted malicious URL can reduce the availability of a Discourse instance. The problem has been patched in version 3.2.3 on the `stable` branch and version 3.3.0.beta3 on the `tests-passed` branch. There are no known workarounds available for this vulnerability.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Discourse vulnerable to DoS through Onebox","id":"CVE-2024-35227","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"discourse:discourse","products":["discourse:discourse"],"type":"denial_of_service","year":"2024"},"n_packages":1,"n_references":3,"next":{"headline":"Improper Handling of Insufficient Permissions in Wagtail","id":"CVE-2024-35228"},"packages":[{"ecosystem":"Bitnami","fixed":["3.2.3"],"introduced":["0"],"last_affected":[],"package":"discourse","purl":"pkg:bitnami/discourse","source":"BIT-discourse-2024-35227"}],"prev":{"headline":"PHP Code Injection by malicious attribute in extends-tag in Smarty","id":"CVE-2024-35226"},"products":["discourse"],"published":"2024-07-03","related":[{"cvss_score":10,"headline":"RCE via malicious SNS subscription payload","id":"CVE-2021-41163","kev_date_added":null,"published":"2021-10-20"},{"cvss_score":9.1,"headline":"Discourse vulnerable to RCE via admins uploading maliciously zipped file","id":"CVE-2022-36066","kev_date_added":null,"published":"2022-09-29"},{"cvss_score":8.9,"headline":"Discourse user account takeover via email and invite link","id":"CVE-2022-39356","kev_date_added":null,"published":"2022-11-02"},{"cvss_score":8.8,"headline":"Discourse vulnerable to Cross-site Scripting in local oneboxes","id":"CVE-2023-22468","kev_date_added":null,"published":"2023-01-26"},{"cvss_score":8.7,"headline":"Discourse leaks private topic title and post excerpt via user action API endpoint","id":"CVE-2026-27934","kev_date_added":null,"published":"2026-03-19"},{"cvss_score":8.7,"headline":"Discourse vulnerable to DoS via large URL payload in PM to a bot","id":"CVE-2025-48053","kev_date_added":null,"published":"2025-06-09"},{"cvss_score":8.6,"headline":"Discourse vulnerable to unlimited mentioned users in message serializer","id":"CVE-2023-48297","kev_date_added":null,"published":"2024-01-12"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["discourse"]},"summary":"Attackers can cause denial of service in Discourse forums by submitting malicious URLs to the Onebox feature.","url":"https://insights.sbomify.com/CVE-2024-35227/"}