{"answers":{"affected":"5 open source packages ship an affected version, including wagtail.","exploited":"There is no known exploitation of CVE-2024-35228 in the wild and no public exploit code.","fix":"Upgrade wagtail to a fixed version for your release line: 6.0.5 or 6.1.2.","what":"CVE-2024-35228 is a medium-severity missing authorization vulnerability in wagtail, published on 30 May 2024. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-35228 and fix it if it is affected.\n\nWhat it is: CVE-2024-35228 is a medium-severity missing authorization vulnerability in wagtail, published on 30 May 2024. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-35228 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wagtail (PyPI): affected from 6.0.0; fixed in 6.0.5, 6.1.2\n- wagtail (PyPI): affected from 6.0.0; fixed in 6.0.5\n- wagtail (PyPI): affected from 6.0.0; fixed in 6.0.5\n- wagtail (PyPI): affected from 6.1.0; fixed in 6.1.2\n- wagtail (PyPI): affected from 6.1.0; fixed in 6.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-35228/ (Markdown: https://insights.sbomify.com/CVE-2024-35228/index.md)","id":"CVE-2024-35228","markdown":"https://insights.sbomify.com/CVE-2024-35228/index.md","name":"CVE-2024-35228","record":{"aliases":["GHSA-xxfm-vmcf-g33f","PYSEC-2026-2032"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Wagtail CMS","requires_auth":"high_privilege","summary":"Authenticated admin users can modify settings without proper permissions due to a missing check in Wagtail's settings module.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-280","name":"Improper Handling of Insufficient Permissions or Privileges"}],"description":"Wagtail is an open source content management system built on Django. Due to an improperly applied permission check in the `wagtail.contrib.settings` module, a user with access to the Wagtail admin and knowledge of the URL of the edit view for a settings model can access and update that setting, even when they have not been granted permission over the model. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. Patched versions have been released as Wagtail 6.0.5 and 6.1.2. Wagtail releases prior to 6.0 are unaffected. Users are advised to upgrade. Site owners who are unable to upgrade to a patched version can avoid the vulnerability in `ModelViewSet` by registering the model as a snippet instead. No workaround is available for `wagtail.contrib.settings`.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Handling of Insufficient Permissions in Wagtail","id":"CVE-2024-35228","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"missing_authorization","year":"2024"},"n_packages":5,"n_references":2,"next":{"headline":"ZKsync Era evaluation order of Yul function arguments","id":"CVE-2024-35229"},"packages":[{"ecosystem":"PyPI","fixed":["6.0.5","6.1.2"],"introduced":["6.0.0","6.1.0"],"last_affected":[],"package":"wagtail","purl":"pkg:pypi/wagtail","source":"PYSEC-2026-2032"},{"ecosystem":"PyPI","fixed":["6.0.5"],"introduced":["6.0.0"],"last_affected":[],"package":"wagtail","purl":null,"source":"GHSA-xxfm-vmcf-g33f"},{"ecosystem":"PyPI","fixed":["6.0.5"],"introduced":["6.0.0"],"last_affected":[],"package":"wagtail","purl":"pkg:pypi/wagtail","source":"GHSA-xxfm-vmcf-g33f"},{"ecosystem":"PyPI","fixed":["6.1.2"],"introduced":["6.1.0"],"last_affected":[],"package":"wagtail","purl":null,"source":"GHSA-xxfm-vmcf-g33f"},{"ecosystem":"PyPI","fixed":["6.1.2"],"introduced":["6.1.0"],"last_affected":[],"package":"wagtail","purl":"pkg:pypi/wagtail","source":"GHSA-xxfm-vmcf-g33f"}],"prev":{"headline":"Discourse vulnerable to DoS through Onebox","id":"CVE-2024-35227"},"products":["wagtail"],"published":"2024-05-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["wagtail"]},"summary":"Authenticated admin users can modify settings without proper permissions due to a missing check in Wagtail's settings module.","url":"https://insights.sbomify.com/CVE-2024-35228/"}