CVE-2024-35230 Welcome and About GeoServer pages communicate version and revision information
GeoServer exposes version and revision details on welcome pages, allowing attackers to identify specific software components for targeted attacks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-35230?
CVE-2024-35230 is a medium-severity vulnerability in geoserver, published on 16 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. In affected versions the welcome and about page includes version and revision information about the software in use (including library and components used). This information is sensitive from a security point of view because it allows software used by the server to be easily identified. This issue has been patched in version 2.26.0 and all users are advised to upgrade. There are no known workarounds for this vulnerability.
Weakness: CWE-200
Which versions are affected by CVE-2024-35230?
4 open source packages ship an affected version, including org.geoserver.web:gs-web-app and org.geoserver.web:gs-web-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.geoserver.web:gs-web-app Maven | From 2.0.0 | 2.25.1 |
org.geoserver.web:gs-web-app Maven | From 2.0.0 | 2.25.1 |
org.geoserver.web:gs-web-core Maven | From 2.0.0 | 2.25.1 |
org.geoserver.web:gs-web-core Maven | From 2.0.0 | 2.25.1 |
Products include Osgeo Geoserver.
How do I fix CVE-2024-35230?
Upgrade org.geoserver.web:gs-web-app to 2.25.1 or later.
Is CVE-2024-35230 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-35230 exists.
Other vulnerabilities in geoserver
- CVE-2023-25157 Unfiltered SQL Injection Vulnerabilities in Geoserver
- CVE-2024-34711 GeoServer has improper ENTITY_RESOLUTION_ALLOWLIST URI validation in XML Processing (SSRF)
- CVE-2023-41339 Unsecured WMS dynamic styling sld=<url> parameter affords blind unauthenticated SSRF in GeoServer
- CVE-2023-43795 WPS Server Side Request Forgery in GeoServer
- CVE-2024-29198 GeoServer Vulnerable to Unauthenticated SSRF via TestWfsPost
Sources
Also known as GHSA-6pfc-w86r-54q6.