{"answers":{"affected":"4 open source packages ship an affected version, including org.geoserver.web:gs-web-app and org.geoserver.web:gs-web-core. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-35230 exists.","fix":"Upgrade org.geoserver.web:gs-web-app to 2.25.1 or later.","what":"CVE-2024-35230 is a medium-severity vulnerability in geoserver, published on 16 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-35230 and fix it if it is affected.\n\nWhat it is: CVE-2024-35230 is a medium-severity vulnerability in geoserver, published on 16 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-35230 exists.\n\nAffected packages and fixed versions:\n- org.geoserver.web:gs-web-app (Maven): affected from 2.0.0; fixed in 2.25.1\n- org.geoserver.web:gs-web-app (Maven): affected from 2.0.0; fixed in 2.25.1\n- org.geoserver.web:gs-web-core (Maven): affected from 2.0.0; fixed in 2.25.1\n- org.geoserver.web:gs-web-core (Maven): affected from 2.0.0; fixed in 2.25.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-35230/ (Markdown: https://insights.sbomify.com/CVE-2024-35230/index.md)","id":"CVE-2024-35230","markdown":"https://insights.sbomify.com/CVE-2024-35230/index.md","name":"CVE-2024-35230","record":{"aliases":["GHSA-6pfc-w86r-54q6"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"GeoServer","requires_auth":"none","summary":"GeoServer exposes version and revision details on welcome pages, allowing attackers to identify specific software components for targeted attacks.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"geoserver","vendor":"osgeo"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. In affected versions the welcome and about page includes version and revision information about the software in use (including library and components used). This information is sensitive from a security point of view because it allows software used by the server to be easily identified. This issue has been patched in version 2.26.0 and all users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Welcome and About GeoServer pages communicate version and revision information","id":"CVE-2024-35230","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":4,"n_references":3,"next":{"headline":"rack-contrib vulnerable to Denial of Service due to the unconstrained value of the incoming \"profiler_runs\" parameter","id":"CVE-2024-35231"},"packages":[{"ecosystem":"Maven","fixed":["2.25.1"],"introduced":["2.0.0"],"last_affected":[],"package":"org.geoserver.web:gs-web-app","purl":null,"source":"GHSA-6pfc-w86r-54q6"},{"ecosystem":"Maven","fixed":["2.25.1"],"introduced":["2.0.0"],"last_affected":[],"package":"org.geoserver.web:gs-web-app","purl":"pkg:maven/org.geoserver.web/gs-web-app","source":"GHSA-6pfc-w86r-54q6"},{"ecosystem":"Maven","fixed":["2.25.1"],"introduced":["2.0.0"],"last_affected":[],"package":"org.geoserver.web:gs-web-core","purl":null,"source":"GHSA-6pfc-w86r-54q6"},{"ecosystem":"Maven","fixed":["2.25.1"],"introduced":["2.0.0"],"last_affected":[],"package":"org.geoserver.web:gs-web-core","purl":"pkg:maven/org.geoserver.web/gs-web-core","source":"GHSA-6pfc-w86r-54q6"}],"prev":{"headline":"ZKsync Era evaluation order of Yul function arguments","id":"CVE-2024-35229"},"products":["geoserver"],"published":"2024-12-16","related":[{"cvss_score":9.8,"headline":"Unfiltered SQL Injection Vulnerabilities in Geoserver","id":"CVE-2023-25157","kev_date_added":null,"published":"2023-02-21"},{"cvss_score":9.3,"headline":"GeoServer has improper ENTITY_RESOLUTION_ALLOWLIST URI validation in XML Processing (SSRF)","id":"CVE-2024-34711","kev_date_added":null,"published":"2025-06-10"},{"cvss_score":8.6,"headline":"Unsecured WMS dynamic styling sld=\u003curl\u003e parameter affords blind unauthenticated SSRF in GeoServer","id":"CVE-2023-41339","kev_date_added":null,"published":"2023-10-24"},{"cvss_score":8.6,"headline":"WPS Server Side Request Forgery in GeoServer","id":"CVE-2023-43795","kev_date_added":null,"published":"2023-10-24"},{"cvss_score":7.5,"headline":"GeoServer Vulnerable to Unauthenticated SSRF via TestWfsPost","id":"CVE-2024-29198","kev_date_added":null,"published":"2025-06-10"},{"cvss_score":7.5,"headline":"GeoServer has an Infinite Loop Vulnerability in Jiffle process","id":"CVE-2025-30145","kev_date_added":null,"published":"2025-06-10"},{"cvss_score":7.5,"headline":"GeoServer allows SSRF via the option for setting a proxy host","id":"CVE-2021-40822","kev_date_added":null,"published":"2022-05-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-12-17","vendors":["geoserver"]},"summary":"GeoServer exposes version and revision details on welcome pages, allowing attackers to identify specific software components for targeted attacks.","url":"https://insights.sbomify.com/CVE-2024-35230/"}