# CVE-2024-35230: Welcome and About GeoServer pages communicate version and revision information

> GeoServer exposes version and revision details on welcome pages, allowing attackers to identify specific software components for targeted attacks.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Dec 2024
- **Updated:** 17 Dec 2024
- **Also known as:** GHSA-6pfc-w86r-54q6

## What is CVE-2024-35230?

CVE-2024-35230 is a medium-severity vulnerability in geoserver, published on 16 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. In affected versions the welcome and about page includes version and revision information about the software in use (including library and components used). This information is sensitive from a security point of view because it allows software used by the server to be easily identified. This issue has been patched in version 2.26.0 and all users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-35230?

4 open source packages ship an affected version, including org.geoserver.web:gs-web-app and org.geoserver.web:gs-web-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.geoserver.web:gs-web-app` | Maven | From 2.0.0 | 2.25.1 |
| `org.geoserver.web:gs-web-app` | Maven | From 2.0.0 | 2.25.1 |
| `org.geoserver.web:gs-web-core` | Maven | From 2.0.0 | 2.25.1 |
| `org.geoserver.web:gs-web-core` | Maven | From 2.0.0 | 2.25.1 |

Products: Osgeo Geoserver.

## How do I fix CVE-2024-35230?

Upgrade org.geoserver.web:gs-web-app to 2.25.1 or later.

## Is CVE-2024-35230 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-35230 exists.

## Other vulnerabilities in geoserver

- [CVE-2023-25157](https://insights.sbomify.com/CVE-2023-25157/): Unfiltered SQL Injection Vulnerabilities in Geoserver (critical 9.8)
- [CVE-2024-34711](https://insights.sbomify.com/CVE-2024-34711/): GeoServer has improper ENTITY_RESOLUTION_ALLOWLIST URI validation in XML Processing (SSRF) (critical 9.3)
- [CVE-2023-41339](https://insights.sbomify.com/CVE-2023-41339/): Unsecured WMS dynamic styling sld=<url> parameter affords blind unauthenticated SSRF in GeoServer (high 8.6)
- [CVE-2023-43795](https://insights.sbomify.com/CVE-2023-43795/): WPS Server Side Request Forgery in GeoServer (high 8.6)
- [CVE-2024-29198](https://insights.sbomify.com/CVE-2024-29198/): GeoServer Vulnerable to Unauthenticated SSRF via TestWfsPost (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-35230 and fix it if it is affected.

What it is: CVE-2024-35230 is a medium-severity vulnerability in geoserver, published on 16 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-35230 exists.

Affected packages and fixed versions:
- org.geoserver.web:gs-web-app (Maven): affected from 2.0.0; fixed in 2.25.1
- org.geoserver.web:gs-web-app (Maven): affected from 2.0.0; fixed in 2.25.1
- org.geoserver.web:gs-web-core (Maven): affected from 2.0.0; fixed in 2.25.1
- org.geoserver.web:gs-web-core (Maven): affected from 2.0.0; fixed in 2.25.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-35230/ (Markdown: https://insights.sbomify.com/CVE-2024-35230/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-35230
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-35230
- OSV: https://osv.dev/vulnerability/CVE-2024-35230

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-35230/
Summaries are generated and may contain mistakes; the official description above is the record.
