{"answers":{"affected":"2 open source packages ship an affected version, including rack-contrib.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-35231 exists.","fix":"Upgrade rack-contrib to 2.5.0 or later.","what":"CVE-2024-35231 is a high-severity denial of service vulnerability in rack-contrib, published on 27 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-35231 and fix it if it is affected.\n\nWhat it is: CVE-2024-35231 is a high-severity denial of service vulnerability in rack-contrib, published on 27 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-35231 exists.\n\nAffected packages and fixed versions:\n- rack-contrib (RubyGems): affected all versions; fixed in 2.5.0\n- rack-contrib (RubyGems): affected all versions; fixed in 2.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-35231/ (Markdown: https://insights.sbomify.com/CVE-2024-35231/index.md)","id":"CVE-2024-35231","markdown":"https://insights.sbomify.com/CVE-2024-35231/index.md","name":"CVE-2024-35231","record":{"aliases":["GHSA-8c8q-2xw3-j869","UBUNTU-CVE-2024-35231"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby Rack middleware","requires_auth":"none","summary":"An attacker can cause a denial of service by sending unconstrained profiler_runs parameters, exhausting server resources in rack-contrib.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"rack-contrib provides contributed rack middleware and utilities for Rack, a Ruby web server interface. Versions of rack-contrib prior to 2.5.0 are vulnerable to denial of service due to the fact that the user controlled data `profiler_runs` was not constrained to any limitation. This would lead to allocating resources on the server side with no limitation and a potential denial of service by remotely user-controlled data. Version 2.5.0 contains a patch for the issue.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"rack-contrib vulnerable to Denial of Service due to the unconstrained value of the incoming \"profiler_runs\" parameter","id":"CVE-2024-35231","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"github.com/huandu/facebook may expose access_token in error message","id":"CVE-2024-35232"},"packages":[{"ecosystem":"RubyGems","fixed":["2.5.0"],"introduced":["0"],"last_affected":[],"package":"rack-contrib","purl":null,"source":"GHSA-8c8q-2xw3-j869"},{"ecosystem":"RubyGems","fixed":["2.5.0"],"introduced":["0"],"last_affected":[],"package":"rack-contrib","purl":"pkg:gem/rack-contrib","source":"GHSA-8c8q-2xw3-j869"}],"prev":{"headline":"Welcome and About GeoServer pages communicate version and revision information","id":"CVE-2024-35230"},"products":["rack-contrib"],"published":"2024-05-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["rack"]},"summary":"An attacker can cause a denial of service by sending unconstrained profiler_runs parameters, exhausting server resources in rack-contrib.","url":"https://insights.sbomify.com/CVE-2024-35231/"}