# CVE-2024-35231: rack-contrib vulnerable to Denial of Service due to the unconstrained value of the incoming "profiler_runs" parameter

> An attacker can cause a denial of service by sending unconstrained profiler_runs parameters, exhausting server resources in rack-contrib.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-8c8q-2xw3-j869, UBUNTU-CVE-2024-35231

## What is CVE-2024-35231?

CVE-2024-35231 is a high-severity denial of service vulnerability in rack-contrib, published on 27 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

rack-contrib provides contributed rack middleware and utilities for Rack, a Ruby web server interface. Versions of rack-contrib prior to 2.5.0 are vulnerable to denial of service due to the fact that the user controlled data `profiler_runs` was not constrained to any limitation. This would lead to allocating resources on the server side with no limitation and a potential denial of service by remotely user-controlled data. Version 2.5.0 contains a patch for the issue.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2024-35231?

2 open source packages ship an affected version, including rack-contrib.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rack-contrib` | RubyGems | All versions | 2.5.0 |
| `rack-contrib` | RubyGems | All versions | 2.5.0 |

## How do I fix CVE-2024-35231?

Upgrade rack-contrib to 2.5.0 or later.

## Is CVE-2024-35231 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-35231 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-35231 and fix it if it is affected.

What it is: CVE-2024-35231 is a high-severity denial of service vulnerability in rack-contrib, published on 27 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-35231 exists.

Affected packages and fixed versions:
- rack-contrib (RubyGems): affected all versions; fixed in 2.5.0
- rack-contrib (RubyGems): affected all versions; fixed in 2.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-35231/ (Markdown: https://insights.sbomify.com/CVE-2024-35231/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-35231
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-35231
- OSV: https://osv.dev/vulnerability/CVE-2024-35231

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-35231/
Summaries are generated and may contain mistakes; the official description above is the record.
