# CVE-2024-35242: Composer vulnerable to command injection via malicious git/hg branch names

> Attackers can execute arbitrary commands by tricking users into cloning repositories with malicious branch names using Composer.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Jun 2024
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-composer-2024-35242, CLEANSTART-2024-DD29597, DEBIAN-CVE-2024-35242, GHSA-v9qv-c7wm-wgmf, UBUNTU-CVE-2024-35242

## What is CVE-2024-35242?

CVE-2024-35242 is a high-severity command injection vulnerability in composer, published on 10 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Composer is a dependency manager for PHP. On the 2.x branch prior to versions 2.2.24 and 2.7.7, the `composer install` command running inside a git/hg repository which has specially crafted branch names can lead to command injection. This requires cloning untrusted repositories. Patches are available in version 2.2.24 for 2.2 LTS or 2.7.7 for mainline. As a workaround, avoid cloning potentially compromised repositories.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2024-35242?

5 open source packages ship an affected version, including composer/composer and composer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `composer/composer` | Packagist | From 2.0 | 2.2.24 |
| `composer/composer` | Packagist | From 2.0 | 2.2.24 |
| `composer/composer` | Packagist | From 2.3 | 2.7.7 |
| `composer/composer` | Packagist | From 2.3 | 2.7.7 |
| `composer` | Bitnami | From 2.0.0 | 2.2.24, 2.7.7 |

## How do I fix CVE-2024-35242?

Upgrade composer/composer to a fixed version for your release line: 2.2.24 or 2.7.7.

## Is CVE-2024-35242 being exploited?

There is no known exploitation of CVE-2024-35242 in the wild and no public exploit code.

Public exploit code:

- A test repository for the vulnerability CVE-2024-35242's PoC (github_poc): https://github.com/KKkai0315/CVE-2024-35242

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-35242 and fix it if it is affected.

What it is: CVE-2024-35242 is a high-severity command injection vulnerability in composer, published on 10 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-35242 in the wild and no public exploit code.

Affected packages and fixed versions:
- composer/composer (Packagist): affected from 2.0; fixed in 2.2.24
- composer/composer (Packagist): affected from 2.0; fixed in 2.2.24
- composer/composer (Packagist): affected from 2.3; fixed in 2.7.7
- composer/composer (Packagist): affected from 2.3; fixed in 2.7.7
- composer (Bitnami): affected from 2.0.0; fixed in 2.2.24, 2.7.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-35242/ (Markdown: https://insights.sbomify.com/CVE-2024-35242/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-35242
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-35242
- OSV: https://osv.dev/vulnerability/CVE-2024-35242

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-35242/
Summaries are generated and may contain mistakes; the official description above is the record.
