CVE-2024-35296 Apache Traffic Server: Invalid Accept-Encoding can force forwarding requests

High 8.2 Published Updated

An attacker can send invalid Accept-Encoding headers to bypass cache lookups, forcing request forwarding and potentially causing denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-35296?

CVE-2024-35296 is a high-severity denial of service vulnerability in Apache Traffic Server, published on 26 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Invalid Accept-Encoding header can cause Apache Traffic Server to fail cache lookup and force forwarding requests.

This issue affects Apache Traffic Server: from 8.0.0 through 8.1.10, from 9.0.0 through 9.2.4.

Users are recommended to upgrade to version 8.1.11 or 9.2.5, which fixes the issue.

Weakness: CWE-20

Which versions are affected by CVE-2024-35296?

It affects 1 product.

Products include Apache Traffic Server.

How do I fix CVE-2024-35296?

Upgrade to a fixed version.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-35296 being exploited?

There is no known exploitation of CVE-2024-35296 in the wild and no public exploit code.

All Apache Traffic Server vulnerabilities

Sources

Also known as DEBIAN-CVE-2024-35296, GHSA-x5fg-377f-962v, OESA-2024-1981, UBUNTU-CVE-2024-35296.

Is CVE-2024-35296 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free