{"answers":{"affected":"2 open source packages ship an affected version, including io.antmedia:ant-media-server.","exploited":"There is no known exploitation of CVE-2024-35371 in the wild and no public exploit code.","fix":"Upgrade io.antmedia:ant-media-server to 2.9.0 or later.","what":"CVE-2024-35371 is a high-severity vulnerability in n/a, published on 29 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-35371 and fix it if it is affected.\n\nWhat it is: CVE-2024-35371 is a high-severity vulnerability in n/a, published on 29 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-35371 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.antmedia:ant-media-server (Maven): affected all versions; fixed in 2.9.0\n- io.antmedia:ant-media-server (Maven): affected all versions; fixed in 2.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-35371/ (Markdown: https://insights.sbomify.com/CVE-2024-35371/index.md)","id":"CVE-2024-35371","markdown":"https://insights.sbomify.com/CVE-2024-35371/index.md","name":"CVE-2024-35371","record":{"aliases":["GHSA-2gx6-qrpp-c4p3"],"analysis":{"component_type":"server_software","fix_type":"no_fix_stated","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Media Server","requires_auth":"none","summary":"Attackers can inject sensitive data into logs due to insufficient sanitization, potentially exposing confidential information to those with log access.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"Ant-Media-Serverv2.8.2 is affected by Improper Output Neutralization for Logs. The vulnerability stems from insufficient input sanitization in the logging mechanism. Without proper filtering or validation, user-controllable data, such as identifiers or other sensitive information, can be included in log entries without restrictions.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ant-Media-Server vulnerable to Improper Output Neutralization for Logs","id":"CVE-2024-35371","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"Code injection in n/a","id":"CVE-2024-35373"},"packages":[{"ecosystem":"Maven","fixed":["2.9.0"],"introduced":["0"],"last_affected":[],"package":"io.antmedia:ant-media-server","purl":null,"source":"GHSA-2gx6-qrpp-c4p3"},{"ecosystem":"Maven","fixed":["2.9.0"],"introduced":["0"],"last_affected":[],"package":"io.antmedia:ant-media-server","purl":"pkg:maven/io.antmedia/ant-media-server","source":"GHSA-2gx6-qrpp-c4p3"}],"prev":{"headline":"Integer overflow in n/a","id":"CVE-2024-35369"},"products":["n/a"],"published":"2024-11-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-12-02","vendors":["n/a"]},"summary":"Attackers can inject sensitive data into logs due to insufficient sanitization, potentially exposing confidential information to those with log access.","url":"https://insights.sbomify.com/CVE-2024-35371/"}