# CVE-2024-35371: Ant-Media-Server vulnerable to Improper Output Neutralization for Logs

> Attackers can inject sensitive data into logs due to insufficient sanitization, potentially exposing confidential information to those with log access.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Nov 2024
- **Updated:** 2 Dec 2024
- **Also known as:** GHSA-2gx6-qrpp-c4p3

## What is CVE-2024-35371?

CVE-2024-35371 is a high-severity vulnerability in n/a, published on 29 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Ant-Media-Serverv2.8.2 is affected by Improper Output Neutralization for Logs. The vulnerability stems from insufficient input sanitization in the logging mechanism. Without proper filtering or validation, user-controllable data, such as identifiers or other sensitive information, can be included in log entries without restrictions.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2024-35371?

2 open source packages ship an affected version, including io.antmedia:ant-media-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.antmedia:ant-media-server` | Maven | All versions | 2.9.0 |
| `io.antmedia:ant-media-server` | Maven | All versions | 2.9.0 |

## How do I fix CVE-2024-35371?

Upgrade io.antmedia:ant-media-server to 2.9.0 or later.

## Is CVE-2024-35371 being exploited?

There is no known exploitation of CVE-2024-35371 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-35371 and fix it if it is affected.

What it is: CVE-2024-35371 is a high-severity vulnerability in n/a, published on 29 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-35371 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.antmedia:ant-media-server (Maven): affected all versions; fixed in 2.9.0
- io.antmedia:ant-media-server (Maven): affected all versions; fixed in 2.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-35371/ (Markdown: https://insights.sbomify.com/CVE-2024-35371/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-35371
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-35371
- OSV: https://osv.dev/vulnerability/CVE-2024-35371

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-35371/
Summaries are generated and may contain mistakes; the official description above is the record.
