# CVE-2024-35374: Mocodo vulnerable to SQL injection in `/web/generate.php`

> Remote attackers can execute arbitrary commands via unsanitized input in Mocodo Online, leading to remote code execution.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 May 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-j6cv-98jx-mrwr, PYSEC-2026-426

## What is CVE-2024-35374?

CVE-2024-35374 is a critical command injection vulnerability in n/a, published on 24 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mocodo Mocodo Online 4.2.6 and below does not properly sanitize the sql_case input field in /web/generate.php, allowing remote attackers to execute arbitrary commands and potentially command injection, leading to remote code execution (RCE) under certain conditions.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2024-35374?

3 open source packages ship an affected version, including mocodo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mocodo` | PyPI | All versions | 4.2.7 |
| `mocodo` | PyPI | All versions | 4.2.7 |
| `mocodo` | PyPI | All versions | 4.2.7 |

Products: Mocodo Mocodo Online.

## How do I fix CVE-2024-35374?

Upgrade mocodo to 4.2.7 or later.

## Is CVE-2024-35374 being exploited?

There is no known exploitation of CVE-2024-35374 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-35373](https://insights.sbomify.com/CVE-2024-35373/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-35374 and fix it if it is affected.

What it is: CVE-2024-35374 is a critical command injection vulnerability in n/a, published on 24 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-35374 in the wild and no public exploit code.

Affected packages and fixed versions:
- mocodo (PyPI): affected all versions; fixed in 4.2.7
- mocodo (PyPI): affected all versions; fixed in 4.2.7
- mocodo (PyPI): affected all versions; fixed in 4.2.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-35374/ (Markdown: https://insights.sbomify.com/CVE-2024-35374/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-35374
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-35374
- OSV: https://osv.dev/vulnerability/CVE-2024-35374

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-35374/
Summaries are generated and may contain mistakes; the official description above is the record.
