CVE-2024-35655 WordPress Brave – Interactive Content plugin <= 0.6.9 - Cross Site Scripting (XSS) vulnerability

Medium 5.9 Published Updated

An attacker can execute arbitrary scripts in the victim's browser via DOM-based XSS in the Brave Interactive Content plugin for WordPress.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-35655?

CVE-2024-35655 is a medium-severity cross-site scripting vulnerability in Brave, published on 4 Jun 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Brave Brave brave-popup-builder allows DOM-Based XSS.This issue affects Brave: from n/a through <= 0.6.9.

Weakness: CWE-79

Which versions are affected by CVE-2024-35655?

2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.

PackageAffectedFixed in
wordpress BitnamiAll versions0.7.0
wordpress-multisite BitnamiAll versions0.7.0

Products include Getbrave Brave.

How do I fix CVE-2024-35655?

Upgrade wordpress to 0.7.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-35655 being exploited?

There is no known exploitation of CVE-2024-35655 in the wild and no public exploit code.

Sources

Also known as BIT-wordpress-2024-35655, BIT-wordpress-multisite-2024-35655, GHSA-83xj-7jxp-xh57.

Is CVE-2024-35655 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free