# CVE-2024-35655: WordPress Brave – Interactive Content plugin <= 0.6.9 - Cross Site Scripting (XSS) vulnerability

> An attacker can execute arbitrary scripts in the victim's browser via DOM-based XSS in the Brave Interactive Content plugin for WordPress.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Jun 2024
- **Updated:** 28 Apr 2026
- **Also known as:** BIT-wordpress-2024-35655, BIT-wordpress-multisite-2024-35655, GHSA-83xj-7jxp-xh57

## What is CVE-2024-35655?

CVE-2024-35655 is a medium-severity cross-site scripting vulnerability in Brave, published on 4 Jun 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Brave Brave brave-popup-builder allows DOM-Based XSS.This issue affects Brave: from n/a through <= 0.6.9.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-35655?

2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wordpress` | Bitnami | All versions | 0.7.0 |
| `wordpress-multisite` | Bitnami | All versions | 0.7.0 |

Products: Getbrave Brave.

## How do I fix CVE-2024-35655?

Upgrade wordpress to 0.7.0 or later.

## Is CVE-2024-35655 being exploited?

There is no known exploitation of CVE-2024-35655 in the wild and no public exploit code.

## Other vulnerabilities in Brave

- [CVE-2023-51534](https://insights.sbomify.com/CVE-2023-51534/): WordPress Brave Popup Builder Plugin <= 0.6.2 is vulnerable to Cross Site Scripting (XSS) (medium 5.9)
- [CVE-2024-43337](https://insights.sbomify.com/CVE-2024-43337/): WordPress Brave plugin <= 0.7.0 - Cross Site Request Forgery (CSRF) vulnerability (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-35655 and fix it if it is affected.

What it is: CVE-2024-35655 is a medium-severity cross-site scripting vulnerability in Brave, published on 4 Jun 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-35655 in the wild and no public exploit code.

Affected packages and fixed versions:
- wordpress (Bitnami): affected all versions; fixed in 0.7.0
- wordpress-multisite (Bitnami): affected all versions; fixed in 0.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-35655/ (Markdown: https://insights.sbomify.com/CVE-2024-35655/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-35655
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-35655
- OSV: https://osv.dev/vulnerability/CVE-2024-35655

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-35655/
Summaries are generated and may contain mistakes; the official description above is the record.
