# CVE-2024-3566: Command injection vulnerability in programing languages on Microsoft Windows operating system.

> Attackers can execute arbitrary commands on Windows systems via vulnerable programming language runtimes using CreateProcess.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Apr 2024
- **Updated:** 18 Nov 2025
- **Also known as:** BIT-node-2024-3566, BIT-node-min-2024-3566, GHSA-9xch-xvj3-fmf3, HSEC-2024-0003, MINI-392m-8v5j-v4j8, MINI-hpmw-pxqr-xhgm

## What is CVE-2024-3566?

CVE-2024-3566 is a critical command injection vulnerability in Nodejs Node.js, published on 10 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A command inject vulnerability allows an attacker to perform command injection on Windows applications that indirectly depend on the CreateProcess function when the specific conditions are satisfied.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2024-3566?

3 open source packages ship an affected version, including node, node-min and process. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node` | Bitnami | From 1.77.2 | 18.19.0 |
| `node-min` | Bitnami | From 1.77.2 | 18.20.5 |
| `process` | Hackage | From 1.0.0.0 | 1.6.23.0 |

Products: Haskell Process Library, Nodejs Node.js, Php Php, Rust-Lang Rust, Yt-Dlp Project Yt-Dlp.

## How do I fix CVE-2024-3566?

Upgrade node to 18.19.0 or later.

## Is CVE-2024-3566 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3566 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-3566 and fix it if it is affected.

What it is: CVE-2024-3566 is a critical command injection vulnerability in Nodejs Node.js, published on 10 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3566 exists.

Affected packages and fixed versions:
- node (Bitnami): affected from 1.77.2; fixed in 18.19.0
- node-min (Bitnami): affected from 1.77.2; fixed in 18.20.5
- process (Hackage): affected from 1.0.0.0; fixed in 1.6.23.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-3566/ (Markdown: https://insights.sbomify.com/CVE-2024-3566/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-3566
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-3566
- OSV: https://osv.dev/vulnerability/CVE-2024-3566

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-3566/
Summaries are generated and may contain mistakes; the official description above is the record.
