# CVE-2024-3568: Arbitrary Code Execution via Deserialization in huggingface/transformers

> Attackers can execute arbitrary code by tricking users into loading malicious checkpoints in the Hugging Face Transformers library.

- **Severity:** Low 3.4 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Apr 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-37q5-v5qm-c9v8, PYSEC-2026-1978

## What is CVE-2024-3568?

CVE-2024-3568 is a low-severity unsafe deserialization vulnerability in huggingface/transformers, published on 10 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The huggingface/transformers library is vulnerable to arbitrary code execution through deserialization of untrusted data within the `load_repo_checkpoint()` function of the `TFPreTrainedModel()` class. Attackers can execute arbitrary code and commands by crafting a malicious serialized payload, exploiting the use of `pickle.load()` on data from potentially untrusted sources. This vulnerability allows for remote code execution (RCE) by deceiving victims into loading a seemingly harmless checkpoint during a normal training process, thereby enabling attackers to execute arbitrary code on the targeted machine.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2024-3568?

3 open source packages ship an affected version, including transformers. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `transformers` | PyPI | All versions | 4.38.0 |
| `transformers` | PyPI | All versions | 4.38.0 |
| `transformers` | PyPI | All versions | 4.38.0 |

Products: Huggingface Transformers.

## How do I fix CVE-2024-3568?

Upgrade transformers to 4.38.0 or later.

## Is CVE-2024-3568 being exploited?

There is no known exploitation of CVE-2024-3568 in the wild and no public exploit code.

Public exploit code:

- This study analyzes Python pickle deserialization vulnerabilities, focusing on CVE-2024-3568 in Hugging Face Transformers' TFAutoModel. We reproduce the exploit to examine its root cause, attack vectors, and risks. (github_poc): https://github.com/rooobeam/Pickle-Deserialization-Exploit-in-Transformers

## Other vulnerabilities in huggingface/transformers

- [CVE-2023-7018](https://insights.sbomify.com/CVE-2023-7018/): Deserialization of Untrusted Data in huggingface/transformers (critical 9.6)
- [CVE-2023-6730](https://insights.sbomify.com/CVE-2023-6730/): Deserialization of Untrusted Data in huggingface/transformers (critical 9.0)
- [CVE-2024-11393](https://insights.sbomify.com/CVE-2024-11393/): Hugging Face Transformers MaskFormer Model Deserialization of Untrusted Data Remote Code Execution Vulnerability (high 8.8)
- [CVE-2024-11394](https://insights.sbomify.com/CVE-2024-11394/): Hugging Face Transformers Trax Model Deserialization of Untrusted Data Remote Code Execution Vulnerability (high 8.8)
- [CVE-2026-5241](https://insights.sbomify.com/CVE-2026-5241/): Policy Bypass in LightGlue Nested Config Resolution in huggingface/transformers (high 8.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-3568 and fix it if it is affected.

What it is: CVE-2024-3568 is a low-severity unsafe deserialization vulnerability in huggingface/transformers, published on 10 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-3568 in the wild and no public exploit code.

Affected packages and fixed versions:
- transformers (PyPI): affected all versions; fixed in 4.38.0
- transformers (PyPI): affected all versions; fixed in 4.38.0
- transformers (PyPI): affected all versions; fixed in 4.38.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-3568/ (Markdown: https://insights.sbomify.com/CVE-2024-3568/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-3568
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-3568
- OSV: https://osv.dev/vulnerability/CVE-2024-3568

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-3568/
Summaries are generated and may contain mistakes; the official description above is the record.
