{"answers":{"affected":"3 open source packages ship an affected version, including langchain. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3571 exists.","fix":"Upgrade langchain to 0.0.353 or later.","what":"CVE-2024-3571 is a medium-severity path traversal vulnerability in langchain-ai/langchain, published on 16 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-3571 and fix it if it is affected.\n\nWhat it is: CVE-2024-3571 is a medium-severity path traversal vulnerability in langchain-ai/langchain, published on 16 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3571 exists.\n\nAffected packages and fixed versions:\n- langchain (PyPI): affected all versions; fixed in 0.0.353\n- langchain (PyPI): affected all versions; fixed in 0.0.353\n- langchain (PyPI): affected all versions; fixed in 0.0.353\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-3571/ (Markdown: https://insights.sbomify.com/CVE-2024-3571/index.md)","id":"CVE-2024-3571","markdown":"https://insights.sbomify.com/CVE-2024-3571/index.md","name":"CVE-2024-3571","record":{"aliases":["GHSA-rgp8-pm28-3759","PYSEC-2026-1510"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python AI library","requires_auth":"low_privilege","summary":"Attackers can read or write arbitrary files via path traversal in LocalFileStore, potentially leading to information disclosure or remote code execution.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[{"product":"langchain","vendor":"langchain"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"langchain-ai/langchain is vulnerable to path traversal due to improper limitation of a pathname to a restricted directory ('Path Traversal') in its LocalFileStore functionality. An attacker can leverage this vulnerability to read or write files anywhere on the filesystem, potentially leading to information disclosure or remote code execution. The issue lies in the handling of file paths in the mset and mget methods, where user-supplied input is not adequately sanitized, allowing directory traversal sequences to reach unintended directories.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Path Traversal in langchain-ai/langchain","id":"CVE-2024-3571","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"XML External Entity (XXE) Vulnerability in scrapy/scrapy","id":"CVE-2024-3572"},"packages":[{"ecosystem":"PyPI","fixed":["0.0.353"],"introduced":["0"],"last_affected":[],"package":"langchain","purl":null,"source":"GHSA-rgp8-pm28-3759"},{"ecosystem":"PyPI","fixed":["0.0.353"],"introduced":["0"],"last_affected":[],"package":"langchain","purl":"pkg:pypi/langchain","source":"GHSA-rgp8-pm28-3759"},{"ecosystem":"PyPI","fixed":["0.0.353"],"introduced":["0"],"last_affected":[],"package":"langchain","purl":"pkg:pypi/langchain","source":"PYSEC-2026-1510"}],"prev":{"headline":"Stored XSS leading to Admin Account Takeover in mintplex-labs/anything-llm","id":"CVE-2024-3570"},"products":["langchain-ai/langchain"],"published":"2024-04-16","related":[{"cvss_score":9.8,"headline":"Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library","id":"CVE-2023-39631","kev_date_added":null,"published":"2023-09-01"},{"cvss_score":9.8,"headline":"langchain vulnerable to arbitrary code execution","id":"CVE-2023-36281","kev_date_added":null,"published":"2023-08-22"},{"cvss_score":9.8,"headline":"LangChain vulnerable to arbitrary code execution","id":"CVE-2023-38860","kev_date_added":null,"published":"2023-08-15"},{"cvss_score":9.8,"headline":"LangChain vulnerable to arbitrary code execution","id":"CVE-2023-38896","kev_date_added":null,"published":"2023-08-15"},{"cvss_score":9.8,"headline":"LangChain vulnerable to arbitrary code execution","id":"CVE-2023-39659","kev_date_added":null,"published":"2023-08-15"},{"cvss_score":9.8,"headline":"langchain Code Injection vulnerability","id":"CVE-2023-36095","kev_date_added":null,"published":"2023-08-05"},{"cvss_score":9.8,"headline":"langchain vulnerable to arbitrary code execution","id":"CVE-2023-36188","kev_date_added":null,"published":"2023-07-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-01","vendors":["langchain-ai"]},"summary":"Attackers can read or write arbitrary files via path traversal in LocalFileStore, potentially leading to information disclosure or remote code execution.","url":"https://insights.sbomify.com/CVE-2024-3571/"}