# CVE-2024-3571: Path Traversal in langchain-ai/langchain

> Attackers can read or write arbitrary files via path traversal in LocalFileStore, potentially leading to information disclosure or remote code execution.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Apr 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-rgp8-pm28-3759, PYSEC-2026-1510

## What is CVE-2024-3571?

CVE-2024-3571 is a medium-severity path traversal vulnerability in langchain-ai/langchain, published on 16 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

langchain-ai/langchain is vulnerable to path traversal due to improper limitation of a pathname to a restricted directory ('Path Traversal') in its LocalFileStore functionality. An attacker can leverage this vulnerability to read or write files anywhere on the filesystem, potentially leading to information disclosure or remote code execution. The issue lies in the handling of file paths in the mset and mget methods, where user-supplied input is not adequately sanitized, allowing directory traversal sequences to reach unintended directories.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-3571?

3 open source packages ship an affected version, including langchain. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langchain` | PyPI | All versions | 0.0.353 |
| `langchain` | PyPI | All versions | 0.0.353 |
| `langchain` | PyPI | All versions | 0.0.353 |

Products: Langchain Langchain.

## How do I fix CVE-2024-3571?

Upgrade langchain to 0.0.353 or later.

## Is CVE-2024-3571 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3571 exists.

## Other vulnerabilities in langchain-ai/langchain

- [CVE-2023-39631](https://insights.sbomify.com/CVE-2023-39631/): Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library (critical 9.8)
- [CVE-2023-36281](https://insights.sbomify.com/CVE-2023-36281/): langchain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-38860](https://insights.sbomify.com/CVE-2023-38860/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-38896](https://insights.sbomify.com/CVE-2023-38896/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-39659](https://insights.sbomify.com/CVE-2023-39659/): LangChain vulnerable to arbitrary code execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-3571 and fix it if it is affected.

What it is: CVE-2024-3571 is a medium-severity path traversal vulnerability in langchain-ai/langchain, published on 16 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3571 exists.

Affected packages and fixed versions:
- langchain (PyPI): affected all versions; fixed in 0.0.353
- langchain (PyPI): affected all versions; fixed in 0.0.353
- langchain (PyPI): affected all versions; fixed in 0.0.353

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-3571/ (Markdown: https://insights.sbomify.com/CVE-2024-3571/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-3571
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-3571
- OSV: https://osv.dev/vulnerability/CVE-2024-3571

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-3571/
Summaries are generated and may contain mistakes; the official description above is the record.
