# CVE-2024-3573: Local File Inclusion (LFI) via Scheme Confusion in mlflow/mlflow

> Attackers can read arbitrary files on the server by exploiting improper URI parsing in MLflow, leading to sensitive data disclosure.

- **Severity:** Critical 9.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Apr 2024
- **Updated:** 1 Aug 2024
- **Also known as:** BIT-mlflow-2024-3573, GHSA-hq88-wg7q-gp4g, PYSEC-2024-243

## What is CVE-2024-3573?

CVE-2024-3573 is a critical path traversal vulnerability in Lfprojects Mlflow, published on 16 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

mlflow/mlflow is vulnerable to Local File Inclusion (LFI) due to improper parsing of URIs, allowing attackers to bypass checks and read arbitrary files on the system. The issue arises from the 'is_local_uri' function's failure to properly handle URIs with empty or 'file' schemes, leading to the misclassification of URIs as non-local. Attackers can exploit this by crafting malicious model versions with specially crafted 'source' parameters, enabling the reading of sensitive files within at least two directory levels from the server's root.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-29 (Path Traversal: '\..\filename')

## Which versions are affected by CVE-2024-3573?

4 open source packages ship an affected version, including mlflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | Bitnami | All versions | 2.10.0 |
| `mlflow` | PyPI | All versions | 2.10.0 |
| `mlflow` | PyPI | All versions | 2.10.0 |
| `mlflow` | PyPI | All versions | 2.10.0 |

Products: Lfprojects Mlflow.

## How do I fix CVE-2024-3573?

Upgrade mlflow to 2.10.0 or later.

## Is CVE-2024-3573 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3573 exists.

## Other vulnerabilities in Lfprojects Mlflow

- [CVE-2026-64849](https://insights.sbomify.com/CVE-2026-64849/): MLflow Server-Side Request Forgery (critical 9.3, exploited in the wild)
- [CVE-2025-15379](https://insights.sbomify.com/CVE-2025-15379/): Command Injection in mlflow/mlflow (critical 10.0)
- [CVE-2024-0520](https://insights.sbomify.com/CVE-2024-0520/): Remote Code Execution due to Full Controlled File Write in mlflow/mlflow (critical 10.0)
- [CVE-2023-6977](https://insights.sbomify.com/CVE-2023-6977/): Path Traversal: '\..\filename' (critical 10.0)
- [CVE-2023-6709](https://insights.sbomify.com/CVE-2023-6709/): Improper Neutralization of Special Elements Used in a Template Engine in mlflow/mlflow (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-3573 and fix it if it is affected.

What it is: CVE-2024-3573 is a critical path traversal vulnerability in Lfprojects Mlflow, published on 16 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3573 exists.

Affected packages and fixed versions:
- mlflow (Bitnami): affected all versions; fixed in 2.10.0
- mlflow (PyPI): affected all versions; fixed in 2.10.0
- mlflow (PyPI): affected all versions; fixed in 2.10.0
- mlflow (PyPI): affected all versions; fixed in 2.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-3573/ (Markdown: https://insights.sbomify.com/CVE-2024-3573/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-3573
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-3573
- OSV: https://osv.dev/vulnerability/CVE-2024-3573

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-3573/
Summaries are generated and may contain mistakes; the official description above is the record.
