# CVE-2024-3584: Path Traversal in qdrant/qdrant

> Attackers can upload files to arbitrary locations via path traversal in the snapshot upload endpoint, potentially leading to system takeover.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 May 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-xcr2-h8hv-6227

## What is CVE-2024-3584?

CVE-2024-3584 is a critical path traversal vulnerability in qdrant/qdrant, published on 30 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

qdrant/qdrant version 1.9.0-dev is vulnerable to path traversal due to improper input validation in the `/collections/{name}/snapshots/upload` endpoint. By manipulating the `name` parameter through URL encoding, an attacker can upload a file to an arbitrary location on the system, such as `/root/poc.txt`. This vulnerability allows for the writing and overwriting of arbitrary files on the server, potentially leading to a full takeover of the system. The issue is fixed in version 1.9.0.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2024-3584?

2 open source packages ship an affected version, including qdrant. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `qdrant` | crates.io | From 1.9.0-dev | 1.9.0 |
| `qdrant` | crates.io | From 1.9.0-dev | 1.9.0 |

Products: Qdrant Qdrant.

## How do I fix CVE-2024-3584?

Upgrade qdrant to 1.9.0 or later.

## Is CVE-2024-3584 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3584 exists.

## Other vulnerabilities in qdrant/qdrant

- [CVE-2024-3829](https://insights.sbomify.com/CVE-2024-3829/): Arbitrary File Read and Write during Snapshot Recovery in qdrant/qdrant (critical 9.8)
- [CVE-2024-2221](https://insights.sbomify.com/CVE-2024-2221/): Path Traversal and Arbitrary File Upload Vulnerability in qdrant/qdrant (critical 9.8)
- [CVE-2026-25628](https://insights.sbomify.com/CVE-2026-25628/): Qdrant affected by arbitrary file write via `/logger` endpoint (high 8.6)
- [CVE-2023-38975](https://insights.sbomify.com/CVE-2023-38975/): Memory corruption in n/a (high 7.5)
- [CVE-2024-3078](https://insights.sbomify.com/CVE-2024-3078/): Qdrant Full Snapshot REST API snapshots.rs path traversal (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-3584 and fix it if it is affected.

What it is: CVE-2024-3584 is a critical path traversal vulnerability in qdrant/qdrant, published on 30 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3584 exists.

Affected packages and fixed versions:
- qdrant (crates.io): affected from 1.9.0-dev; fixed in 1.9.0
- qdrant (crates.io): affected from 1.9.0-dev; fixed in 1.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-3584/ (Markdown: https://insights.sbomify.com/CVE-2024-3584/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-3584
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-3584
- OSV: https://osv.dev/vulnerability/CVE-2024-3584

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-3584/
Summaries are generated and may contain mistakes; the official description above is the record.
