# CVE-2024-36077: Privilege escalation in n/a

> Remote attackers can elevate privileges to the internal system role and execute commands on the server due to improper validation.

- **Severity:** High 8.8 (`CVSS:3.1/AC:L/AV:N/A:H/C:H/I:H/PR:L/S:U/UI:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 22 May 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-8qvr-jr3j-p3rg

## What is CVE-2024-36077?

CVE-2024-36077 is a high-severity vulnerability in n/a, published on 22 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Qlik Sense Enterprise for Windows before 14.187.4 allows a remote attacker to elevate their privilege due to improper validation. The attacker can elevate their privilege to the internal system role, which allows them to execute commands on the server. This affects February 2024 Patch 3 (14.173.3 through 14.173.7), November 2023 Patch 8 (14.159.4 through 14.159.13), August 2023 Patch 13 (14.139.3 through 14.139.20), May 2023 Patch 15 (14.129.3 through 14.129.22), February 2023 Patch 13 (14.113.1 through 14.113.18), November 2022 Patch 13 (14.97.2 through 14.97.18), August 2022 Patch 16 (14.78.3 through 14.78.23), and May 2022 Patch 17 (14.67.7 through 14.67.31). This has been fixed in May 2024 (14.187.4), February 2024 Patch 4 (14.173.8), November 2023 Patch 9 (14.159.14), August 2023 Patch 14 (14.139.21), May 2023 Patch 16 (14.129.23), February 2023 Patch 14 (14.113.19), November 2022 Patch 14 (14.97.19), August 2022 Patch 17 (14.78.25), and May 2022 Patch 18 (14.67.34).

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2024-36077?


## How do I fix CVE-2024-36077?

No fix has been published for CVE-2024-36077 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-36077 being exploited?

There is no known exploitation of CVE-2024-36077 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-36077 and fix it if it is affected.

What it is: CVE-2024-36077 is a high-severity vulnerability in n/a, published on 22 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-36077 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-36077/ (Markdown: https://insights.sbomify.com/CVE-2024-36077/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-36077
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-36077
- OSV: https://osv.dev/vulnerability/CVE-2024-36077

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-36077/
Summaries are generated and may contain mistakes; the official description above is the record.
