CVE-2024-36105 dbt allows Binding to an Unrestricted IP Address via socketsocket
dbt-core exposed documentation servers on all network interfaces, allowing unauthorized remote access to data on unsecured networks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-36105?
CVE-2024-36105 is a medium-severity vulnerability in dbt-labs dbt-core, published on 27 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
dbt enables data analysts and engineers to transform their data using the same practices that software engineers use to build applications. Prior to versions 1.6.15, 1.7.15, and 1.8.1, Binding to `INADDR_ANY (0.0.0.0)` or `IN6ADDR_ANY (::)` exposes an application on all network interfaces, increasing the risk of unauthorized access. As stated in the Python docs, a special form for address is accepted instead of a host address: `''` represents `INADDR_ANY`, equivalent to `"0.0.0.0"`. On systems with IPv6, '' represents `IN6ADDR_ANY`, which is equivalent to `"::"`. A user who serves docs on an unsecured public network, may unknowingly be hosting an unsecured (http) web site for any remote user/system to access on the same network. The issue has has been mitigated in dbt-core v1.6.15, dbt-core v1.7.15, and dbt-core v1.8.1 by binding to localhost explicitly by default in `dbt docs serve`.
Weakness: CWE-1327
Which versions are affected by CVE-2024-36105?
7 open source packages ship an affected version, including dbt-core.
| Package | Affected | Fixed in |
|---|---|---|
dbt-core PyPI | All versions | 1.6.15, 1.7.15, 1.8.1 |
dbt-core PyPI | All versions | 1.6.15 |
dbt-core PyPI | All versions | 1.6.15 |
dbt-core PyPI | From 1.7.0 | 1.7.15 |
dbt-core PyPI | From 1.7.0 | 1.7.15 |
dbt-core PyPI | From 1.8.0 | 1.8.1 |
1 more packages
dbt-core PyPI | From 1.8.0 | 1.8.1 |
How do I fix CVE-2024-36105?
Upgrade dbt-core to a fixed version for your release line: 1.6.15, 1.7.15 or 1.8.1.
Is CVE-2024-36105 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-36105 exists.
Sources
Also known as GHSA-pmrx-695r-4349, PYSEC-2026-1292.